How to give Picard snap package file system access

I realize this is more a snap issue than a Picard issue but it’s a real problem for me and it drives me crazy.

As per the official snap philosophy that a snap application may not have access to anything that doesn’t live in the user’s home directory or possibly a USB stick, I can’t get my freshly installed Picard to access things like /data and /data2 (where I have my ecrypted data filesystems mounted). Very secure - I can’t access any of my music!

If it were up to me I’d just prefer to give all my snap applications full rootfs access, but that’s not possible without doing really ugly things (the software equivalent to ramming a crowbar into the works) so I’ll settle for any way to give Picard access to /data and /data2. How do I do that?

Snap doesn’t allow to give access to arbitrary file system locations. Picard has access to your home folder and you can give it access to “removable media” which AFAIK gives access to things mounted under /media or the user specific directory in /run/media.

The access to removable media should be auto connected, but if not see Download & Install Picard — MusicBrainz Picard v2.11 documentation

So one option would be to mount the data filesystems under one of the above locations.

If you want to access other locations I suggest you either install Picard via package management or use the Flatpak version.

Flatpak allows giving applications access to arbitrary file system locations. I’d need to lookup the exact command, but if I think this also has been discussed somewhere here in the forums.


Thank you! :grinning: I’ve managed to resolve it by means of a bind mount under /media. It’s a gobbingly ugly kludge, but it’ll get me there for now.

Man, I hate snap…