How to determine if Scan function is working

musicbrainz
acoustid
audiofingerprinting
scan
Tags: #<Tag:0x00007f11c712e7d0> #<Tag:0x00007f11c712e528> #<Tag:0x00007f11c712e3e8> #<Tag:0x00007f11c712e2a8>

#1

I have tried multiple times to get the Scan function to work to identify a song. As far as I can tell, nothing is happening. I don’t see any songs identified and I don’t see any status or error messages generated about the failure to identify a song signature. I signed up for an account at AcousticID and got an API key value to plug into the MB Fingerprinting preferences.

Is there any test I can perform to try to identify what might be happening?

Thanks.


#2

A few things to check:

  1. If you scan a file you should afterwards see a AcoustId tag in the tags like this:

    If the file gets an AcoustId that means fpcalc is working. If it does not load a result from MusicBrainz this just means the AcoustId is not mapped to a recording on MusicBrainz yet or the recording is not in MusicBrainz at all. You can fix this by adding the recording to MusicBrainz and/or load the recording into Picard. Then drag your file to that recording and use “Submit AcoustIDs” to link this AcoustId to this recording.

  2. Try with multiple files if any of them produces a fingerprint. Not all files will get processed by fpcalc, e.g. if it is only a few seconds long or in a format not supported by fpcalc.

  3. Check Help -> View Error/Debug Log for error messages


Scan option Not Working on Most Files
#3

Thanks for your feedback. I tried again to fingerprint a song, but nothing happened again. I checked the error log and it said E: 11:07:46,828 acoustid._on_fpcalc_finished:170: Fingerprint calculator failed exit code = 3, exit status = 0, error = Unknown error
I looked at the preferences for fingerprinting and the version of fpcalc shown was 1.4.3.

I tried looking up the error message but didn’t find anything helpful. Any other ideas would be welcomed. Thanks.


#4

Ok, that’s interesting. If it shows the version in Options that means fpcalc itself is found and works in general. 1.4.3 is also the latest version.

So my guess is on fpcalc having a problem with the file. What kind of file is it?


#5

The file I used is an mp3, as are most of my files. I would think that format should work.


#6

I did a bit more experimenting to try to figure out the problem with fpcalc. The first experiment was to load an older version of fpcalc. I used the previous version 1.4.2 and it failed, but the error code was slightly different - E: 19:09:57,546 acoustid._on_fpcalc_finished:170: Fingerprint calculator failed exit code = 2, exit status = 0, error = Unknown error In this case the exit code was 2 rather than 3 when I used fpcalc ver. 1.4.3.

the second experiment was to load a Windows version of MusicBrainz in a Parallels virtual machine running Windows 7. Using the same music file - the scan operation worked properly. I would hate to resort to using Windows in order to get Scan to work.

Any other ideas for how to diagnose the problem with the Mac version of MB?