Host not found error when downloading coverart

I’ve been getting this error on one specific release, but not others:

E: 15:48:42,276 webservice._handle_reply:396: Network request error for : Host not found (QT code 3, HTTP code 0)
E: 15:48:42,276 album.error_append:278: Coverart error: Host not found

In Options, I have CAA, Local Files, and CAA Release Group enabled. The weird thing is the “host not found” bit. Seems like that would affect all releases, or none of them. In fact, if I use the Other Versions menu to select a different version, I don’t get the error - it’s just one specific version of one release:

If I click on the More Details button in the cover art pane, it crashes Picard entirely.

Very weird issue, I tried to reproduce it without success.

Which system and Picard version are you running?

Can you enable debug log as described in and share it in a bug report?


v2.3.1 Bug has been created here:

I wasn’t sure where to look for a log file post-crash, so the log I uploaded was just for the initial error.

Thanks a lot, your debug log helped me to find the (trivial) issue which is there since years, which should be fixed in next release.
It is triggered by PDF cover art images, so it should only happen with releases having such and when Picard user has enabled all cover art options required for those to be downloaded.


Wow - thanks for the quick fix!


Not sure which version it was, but I’m still getting it:
“Host not found (QT code 3, HTTP code 0)”
but also
“server replied: Too Many Requests (QT code 299, HTTP code 429)”

Running on MacOS 11.4.
It looks like a server issue to me, probably overloaded. Or even a hosting issue when the server can’t cope with the number of requests and blacks out altogether causing a host not found error, because minutes before or some minutes later it works again.

Yes, we have a rate limiter on coverarchive since few months, to limit load on backend servers.
That’s a temporary error. If it happens too much, ping us again, we’ll try to find a solution.


So I should slow down, right? :smiley: LOL…

this seems to have become a problem again today. all requests to coverartarchive are being rejected. “too many requests”. I had three albums i was trying to retrieve data for - surely that isn’t too many??

1 Like

I’m having problems, too.

CAA JASON error: Too Many Requests


Same problem here. And i was not doing anything intensive. Given that there are a few recent comments in the last few hours i wonder if there isn’t some backend issue…

1 Like

At least it seems to be something general, not user specific. Just tried (link from the documentation), and instantly got that 429 Too Many Requests response.

1 Like