Help with medleys

Hi all,

I added Log In - MusicBrainz by importing from Discogs. However, on the CD, there are only 8 tracks, so if I now import the release with, the number of tracks does not match. Some help appreciated in fixing this.

The track names are:

  • Magical Medley (Beatles Version Club)
  • Rhythm ’n’ Blues Medley
  • Slow Medley
  • Bee Gees Medley (Dance Night Fever Medley)
  • Beach Boys Medley
  • Discollection
  • Dan’s
  • Choo-Choo (Medley)
  • Magical Medley (Beatles House Version)

Cheers, H.

Hi @hamaryns,

Thanks for your time trying to enter this data. And thanks for asking because it seems that it is not the proper way to enter it on MusicBrainz indeed.

Since you mentioned that your CD has only 8 tracks, so should be the release you enter on MusicBrainz.

(I don’t know if the linked release on Discogs is the same release entered following a track-listing convention specific to Discogs, or if it is the a different release with 92 split tracks. So let’s ignore it for now.)

So I suggest you to use MusicBrainz Picard to submit the CD release (with AcoustID fingerprints and DiscID) instead; See Submitting Cluster as a Release — MusicBrainz Picard v2.8.3 documentation

If the track titles don’t come with the CD and cannot be found on the Web, then use the name of each song in the medley separated by space, slash, space; See Style / Titles - MusicBrainz

Once the release is entered with proper track titles, then you can think about linking recordings to works; See How to Use Works - MusicBrainz



Thanks for your answer. I installed Picard, added the files, but there is no option ‘Submit as release’. See screenshot.

What now?

Cheers, H.

1 Like

That menu should have something after Verwijderen


(Edit: Updated image to Dutch from v2.8.3)


Which version of Picard do you have? It should be there if you have 2.7 or later, otherwise you have to enable “Submit as release” in plugins.


Aha, from @IvanDobsky’s picture you can see that it is a plugin which is obviously not installed in my situation. I just took the picard from the Linux Mint software manager and indeed it is only 2.3.1. I installed 2.8 from Flatpak now and indeed now there is the option by default, as shown in the docs.
Thanks all.