Help to troubleshoot frequent MB VM/PostgreSQL/pgAdmin error

Tags: #<Tag:0x00007f9ad9a96d68> #<Tag:0x00007f9ad9a96b10> #<Tag:0x00007f9ad9a969d0>

Hi, I’m using VirtualBox to create a virtual MB server to then connect to it from pgAdmin.

Everytime I try to run PostGre pgAdmin, I’m seeing this annoying error, which I then have to shut down the VM so this error goes away.
However, I’d like to know what causes this (I’m not sure if closing and restarting will fix the issue this time anyway).
Thanks in advance.

Hi @jrsousa2, are you able to connect to the MusicBrainz database of the VM from your host (using pgAdmin or any other tool)? If not, please check connecting additional ports, otherwise you should probably investigate pgAdmin.

2 Likes

It connects, but at times even connected I can’t run queries, it gives me this error, whose description I posted above.

It doesn’t seem to successfully connect…

Try connecting to the MB VM database using another tool from your host (e.g. psql) and running a simple query. If that works, then it is most probably an issue from pgAdmin configuration.

What pisses me off is that it seems to happen all the effing time and at random.
It fails, then I have to shut down and restart the VM, and then it works.
Effing annoying thing.

It’s so effing annoying, each time I run this pest, I get this absolutely annoying error below (which comes out of nowhere.)

I say out of nowhere because this error is issued even before I run any query, and also cause it works every other day, which drives me absolutely nuts. Who said windows sucks, Ubuntu/open source software are much worse (gifted horse have no teeth, or something like that).

postGre is so shitty that they don’t even have this error listed in their stupid site.

Unless you found the source of this issue, it is difficult to tell which part is causing that. It could be caused by PostgreSQL, pgAdmin, VirtualBox, Ubuntu guest system, or Windows host system. So far, this error message comes from pgAdmin. Is there anything relevant in the logs of other parts?

2 Likes

This post was flagged by the community and is temporarily hidden.

This is why I fear using these pseudo-fancy open-source OS’s, they are arcane and impractical, you have to spend a long time typing insanely long sequences of commands to achieve things that should be simple and done automatically. It doesn’t accept copy and past into the command bar.

Anyway, can someone please help me troubleshoot this annoying error? I have no idea why it’s erroring out. I’m not too familiar with Linux, or virtual machine servers.

I no longer have this issue, I shut down the VM and restarted, and then it went back to normal. Have no idea what caused this.

!

1 Like