Green tagger button


Hi. I just started using Picard and I’m having a little trouble following the instructions. I’m trying to find the “green tagger button” that’s mentioned in the quick start guide but I don’t see it next to any of the albums on the website. What am I missing?



Did you use the “lookup in browser” command in Picard first? I don’t think it will show up until you do that.


Thanks for the quick reply.

I tried it using the lookup in browser button and also by searching the site. I even tried more popular or well-known artists in case it doesn’t show up for obscure ones, but still no pretty green buttons.


If it’s there for any it will be there for all. Where are you looking for it? On the release page?


Do you have cookies disabled by any chance? This whole thing works by appending the tport parameter to the URL. Picard sets this parameter when you open from Picard via the lookup in browser. Once set this gets rembered for the browser session.


@psychoadept – That’s the problem, it’s not there for any of them. Also, I don’t know what the release page is so I can’t answer that for sure, but I think I’m on a release page. I see “release”, “release by”, “release group”, etc. on the pages and also in the title bar of my browser. But even when I get to a page that says “Tag Lookup Results” like in the quick start screenshot, there isn’t a green tagger button.

@outsidecontext – No, cookies aren’t disabled.

I’ve tried a few different types of search results in three browsers (Chrome, MS Edge and MSIE) to see if I had an extension or plugin of some kind preventing the green button to show but the pages I looked at looked the same in all the browsers. Here is one example and here’s another.

It’s okay if it doesn’t work. I’ve only got a handful of albums left that are super messed up and need to be fixed so I can just do them manually.

But I have one last question, just out of curiosity. In the documentation for Picard, under Basics, it says “use one of the lower “Lookup” buttons in Picard”. What is a lower lookup button? I only have the three (lookup, scan and lookup in browser) in the menu bar at the top of the screen. Are there other lookup buttons?


I just happened to click on FAQs under Picard’s Documentation menu and saw the first FAQ and then I remembered your post about the tport parameter.

The green “Tagger” icon disappeared from, how do I get it back?

This icon shows up when a manual lookup is performed via Picard (using the bottom “Lookup” button).

Alternatively the parameter ?tport=8000 can be added to the end of almost any MusicBrainz URL and the green tagger icons will continue to show up from then on.

My only experience with a listening port is limited to P2P applications and since I wasn’t sure how or why Picard needed one, I disabled it. After re-enabling it, I do have the helpful little green tagger button and it works perfectly (it didn’t work when I tried a manual lookup, though).

I’m still curious about the lower (or bottom) “lookup” button. :slight_smile:


There have been a lot of changes to Picard UI recently. “Bottom” is out of date. It’s the lookup in browser button that matters for this.

By the way, you can also paste the url for a release into Picard and it will load it.


That sounds really helpful. Where would I paste it?


In that search box which should be at the top left


Or you drag and drop the URL into the Picard window, this works too


@outsidecontext – I tried drag and drop before posting about it originally and it looked like it was going to work (I get a plus sign with a box around it while dragging inside either window pane) but nothing happens when I drop.

@psychoadept – I hadn’t noticed the search box before. Mine is in the upper right hand corner and I have Picard in split screen mode making the box pretty small. Anyway, dragging the tagger button side the box and clicking the magnifying glass worked. Nice!

Thanks again to both of you.


You are right, doesn’t work for me, either. Might be a bug.


Maybe. Seems I’ve been encountering a lot of “bugs” on a lot of sites and in a lot of my software since I had to have Windows 10 reinstalled on my computer. Maybe it has to do with security and safety settings? I was pretty lax before and now all my settings have been reset to default.


Now it is working for me again and I cannot reproduce. Not quite sure. For your case: Unless you are running Picard with elevated rights under Windows there should be no issue with drag and drop caused by security settings.


I don’t know what elevated rights are but I am having issues with Windows security settings and Picard, mostly with automatically and/or manually deleting folders after changes have been made. I was going to post a question about them but the issues aren’t consistent and I was having trouble describing them in a concise way so I gave up. I’m still trying to get my computer “back to normal” since getting it back and I think some of these problems will fix themselves when I do.