German umlauts removed in picard

Hi,

I’ve recognized that german umlauts were trancoded (like ü -> u) in tag information. First I thought that the umlaut is missing in musicbrainz but like this one
https://musicbrainz.org/recording/ae25aa48-b627-4a70-b69f-eee1062dda93
the umlaut is correct but in picard it is missing. Where can I disable this behaviour in picard?
I have disabled Metadata -> Convert Unicode punctuation characters to ASCII

Thanks!

Works here, the data is correctly loaded into Picard and saved to tags.

What file format do you tag? What software do you use to read the tags?

I tag mp3s with ID3v2 2.4 and UTF-8.
I just tested it on a different PC (both Ubuntu 19.10). There it works. I compared both configurations and they are equal. The first PC where it does not work runs picard 2.2.3 (PPA) the second one picard 2.1.3. So I thought of a bug but installing picard 2.1.3 (repository) on the first PC gives the same result - no umlauts on that PC.
Any ideas?

That’s strange. How do you verify the tags written to the files? If you just load the affected file back into Picard does it show the umlaut in the “Original value” column for the tags or not?

Very strange. It showed the original value with umlaut. The new value from MusicBrainz was without umlaut in the tag cell whereas I checked the MusicBrainz value with has an umlaut.

However, I fixed it!
I’ve removed
~/.config/MusicBrainz
and started with a fresh configuration. This is working with umlauts as it should. I set all options exactly the same as before and the umlauts are still there. Maybe a bug in the configuration file after many updates over the years?

Best regards

3 Likes

It’s interesting, yes. I will dig the source code for some hints. You don’t happen to have a backup of the now deleted config file? I would be interested seeing this :smiley:

1 Like

Of course I have a backup. :wink:
What do you need? Picard.conf or Picard.ini?

Here are the config files:

I’ve removed API keys…

Best regards

5 Likes

Thanks a lot. I think I found the offender: You had the non_ascii_equivalents enabled.

And it does replace the ü, it’s kind of the sole point of this plugin ;).

Sometimes Picard being so extensible can cause headaches when giving support :smiley:

4 Likes

Ah, perfect, thank you very much! :+1: