Freezing After Updating from 1.3 to 1.4.1


#1

I use Picard to manage my music collection of about 450 songs. I never had any trouble with the program until I updated today to version 1.4.1 Now, the program will hang and crash if I load more than one song at a time into it. Usually it seems to do this when it tries to look up album information. Because it doesn’t do a hard crash, I don’t seem to be generating any log files.

Any advice would be helpful. Thank you.


#2

Could you tell us what operating system you use?


#3

Also could you explain more what you mean with it crashes, but not hard?


#4

Can you link to a debug log ?


#5

Hello, and thank you for the replies.

I’m using Windows 10, computer specs are AMD Phenom x8 processor running at 3.2ghz and 32gb of RAM (so my specs are probably not the issue).

By “hard crash”, I mean one where the program terminates by itself. I’m having “soft crash” problems, where in the program begins to not respond and I have to close it manually using the task manager.

I did more testing after I posted, and it seems like the problem happens when it tries to communicate with the MusicBrainz server. It will claim to be downloading information and either freeze at that point, or when the download is complete and 0 items are in queue, it won’t update any of the information it just downloaded and often just says [loading album information]. And yes, I am running it as an administrator. I’ve also tried disabling plugins, instructing it to overwrite old MBID data, and even tried manually using the tagger to hook albums from the website directly. Every time I get [loading album information] or a soft crash freeze. I also tried doing a complete reinstallation, including wiping settings from old installs.

As for the debug log, I’d be happy to provide one. Can you tell me where I can find one or how I can generate one please? Thanks!

EDIT: I figured out how to debug, although I don’t know where logs are saved after putting -d in the command line. However, using the debug log, I was able to see what songs were causing the hold ups, so I manually pulled them out of my sort order and used browser look up to find their albums and manually assign them. That fixed it to the point that I can now run it automatically on the rest of the songs. I’m not sure why it those three songs were doing this.

On another note, a separate problem (the [loading album information] problem) was being caused by the old Last.fm plugin I had enabled. For whatever reason, even when I disabled plugins, it would keep them enabled. I had to reset my preferences to default to clear it, but once it was cleared, that fixed the issue.

Any further suggestions for optimization are always appreciated though.


#6

I’m also having the same issue, Fresh install of Windows 10 64-bit, anything I load into musicbrainz causes it to hang and become unresponsive, only closable via task manager :frowning:


#7

Bewinxed, did you try the things I did to get it working? Open your debug dialog, and see where there error is occurring. If it happens during a plugin’s load, then disable the plugin; if it is happening over a certain song, you may have to manually load the song information from a browser and drag and drop it onto the match.

Not really solutions, so much as work arounds, but maybe they will help.


#8

For some reason it started working again with no issues, Very weird.

[Edit] Nope, Spoke too soon, some songs trigger it, where can we find the log file? the log can’t be used in-app since the log and the app hangs as well.


#9

About the debug log, read https://picard.musicbrainz.org/docs/troubleshooting/ Getting logs section.

You can enable it from UI, in Help > View Error/Debug Log, there is a checkbox on the bottom (Debug mode) to enable/disable it during runtime.

The best is to enable debug mode from command line because it will show information about startup.


#10

I have windows 7, 64-bit, the program would open, but ‘hang’ when I added a music folder, installing this fixed the issue:

If you get an error about being unable to run the program, install the Microsoft Visual C++ 2008 Redistributable Package (x86). https://picard.musicbrainz.org/downloads/

https://www.microsoft.com/en-us/download/details.aspx?id=29


#11

I spoke too soon, something is still happening when trying to add files