Folder permission on Synology

newbie question.I installed a package called Picard MusicBrainz on my synology and I can log in to the URL apps running fine. However, when I select a folder to scan the files inside the folder, there no files to be found. I’ve added the folder volume within the Docker image. Is there permission I need to set some place? And if so can someone please provide how that is done, please and thank you in advance

I am a bit confused, but I also don’t know Synology NAS very well.

So how did you install Picard and where do you have Picard installed, on your local PC or somehow on the Synology itself? How do you run it?

And what kind of docker image is this and how is that involved?

I found something, there is a docker image for Picard at mikenye/picard. The GUI then can be accessed via we browser. So probably it is this that you have installed on your NAS, right?

This is the first time I see this, didn’t know something like this existed.

Their docs say to run it like this:

docker run -d \
    --name=picard \
    -p 5800:5800 \
    -v /path/to/config:/config:rw \
    -v /path/to/music:/storage:rw \
    mikenye/picard

Important is the part where the music directory is specified with -v /path/to/music:/storage:rw. So in your case /path/to/music should be set to the path containing your music files as it is internally on your NAS. I would keep /storage as is. The inside Picard you would need to navigate to the /storage directory.

If add folder does not add anything, try the file browser or add files. Do those two show the content (sub directories and files) of storage? If not, either your path for the volume is wrong or there are permission settings.

Otherwise open Help > View error/debug log, enable debug mode in the log window and try to use add folder again. Share the content of the log window here.

1 Like

At first glance, this seems to me to be rather exaggerated and overcomplicated. What would be the benefit of such a solution?

2 Likes

It is. The one benefit this has is that this way you can run Picard directly on servers (or e.g. a NAS) and access the files there locally, without having to transfer files between your desktop computer and the server.

@robert.wynter Just to be clear on this: I’m happy to debug this a bit with you. But if this does not work, I would really recommend to install Picard the normal way using the official installer from picard.muiscbrainz.org/downloads . Or ask the author of the docker file for help.

2 Likes

Thanks for the follow-up. I reached to the author and he help. It was a permissions thing. I SSh into my server, right mouse clicked on the volume folder where the music resides and updated the permissions now I can see the files.

Also FYI I originally went to https://picard.musicbrainz.org/downloads/, however, I did not see a download for Synology NAS.

2 Likes

Also FYI I originally went to https://picard.musicbrainz.org/downloads/, however, I did not see a download for Synology NAS.

Yes, there is none. Picard is a desktop application and is supposed to be run on your local computer. That docker image version allows you to run it on your NAS directly, but this is not officially supported.

1 Like

I gave this docker image a try, it is actually pretty fascinating using Picard UI inside a browser window that way. And things seem to be fully functional. Only thing I could not get to work was granting the docker image access to my CD drive, but that’s probably just a permission issue again. And even the lookup in browser functionality is working, the docker image comes with a Chromium browser. So when Picard opens anything in a browser it opens a Chromium window (still all inside your browser tab).

We won’t officially support this, but it’s one of the great things about free software that people can do stuff like this.

3 Likes