[FIXED] Quote button issue

Tags: #<Tag:0x00007f510de544e8> #<Tag:0x00007f510de54420>

FIXED


Since a few days, I cannot use Discourse inline Quote button when I select text spanning over several paragraphs or going through italic, bold, user mention, code, etc.
I also tried with the default skin/theme, same bug.

I use Firefox 78.5.0esr (64 bits) on Debian 10.
I have just tested same issue with Vivaldi 3.4.2066.106 (Stable channel) (64 bits) on Windows 10.
They are the latest versions of both browsers.

The Quote button does appear when I select a few words of plain text only, now.

Have we change anything recently on our Discourse?

I cannot reproduce this bug at meta.discourse.org but they have a more recent beta version.

It happened on other Discourse forums as well and, as they cannot reproduce on meta, they put the blame on non-standard plugins. :thinking:


Please try with your browser if the Quote button appears when you try to quote my post by selecting from “I cannot reproduce this bug at” to “a more recent beta version. It happened”:

Screen capture of the selection I mean

3 Likes

Yes, +1
Same behavior on latest Google Chrome (Version 87.0.4280.88 64-Bit) on Windows 10 Pro 20H2, 64bit

1 Like

Ah - glad it isn’t just me. (Vivaldi user). I had that problem earlier. After reading your post I notice in my example that having the MB shortcut hover text thingy in there blocked the Quote, so did an emoticon, italics or new line. But highlight text without and it was working.

Sure it was working a couple of days ago.

1 Like

Discourse was upgraded few days ago.
@Freso can you check if this issue relates to any plugins?

2 Likes

I forgot to tell I first noticed the bug on Android Firefox 68.
Android Chrome also has the bug.

@Freso, could you please try to temporarily remove Abbreviation plugin and all plugins in fact, to see which one may cause this Quote button bug?

It’s quite inconvenient. :slight_smile:

4 Likes

My trick is to select part of the quote, up to the Abbreviation. That lets me start the reply. I then return to copy\paste the rest of the text from the original quote as needed.

2 Likes

The other workaround, if you want to copy the formatting, is to Reply then click the :speech_balloon: Quote whole post balloon and remove unwanted text. :wink:

But we loose time in either case. :wink:

4 Likes

For those searching the “Quote whole post balloon” after pressing Reply/Antworten

Quote button issue

1 Like

Totally agree. To do that quote above I had to faff around and work out which smiley to find. Meaning they are not real quotes anymore.

Trouble is, that shows that you can’t turn anything off in the forum to make quick quote work. Otherwise smileys :grin: also have to go, along with MB abbrevs, paragraphs, @jesus2099 user quotes… anything that isn’t plain text triggers the bug feature.

Our only choice is turning up on the discourse forums with flaming pitchforks and start a riot. (Why isn’t there a riot emoji?)

1 Like

:slight_smile: I reported it already (see OP) and they tell us to try without plugins, because there is no bugs over there. First step to see if it comes from a plugin.

I mean our plugin (abbreviations) certainly did not change, but some change in Discourse broke the compatibility or something? Or it’s maybe not even at all because of any plugins. We’ll find out…

1 Like

Ah - the standard dev excuse. Clearly we are holding it wrong. :grin: The fact it bugs out with so many ways that isn’t the abbreviations makes me wonder about that excuse.

I create a ticket now to not forget it:

1 Like

It’s fixed on mobile (Firefox for Android 68.11.0)!

But still bug in desktop.

1 Like

It seems to work too in the newest Google Chrome Version 89.0.4389.90 and FireFox v86 (32-bit) and v87 on Windows 10 Pro.

1 Like

It’s now OK too on Chromium 88.0.4324.187 Linux (Raspbian 10).

Strange, it is still the same issue for me with Firefox 87.0 (64-bit), I had to add the “Pro” to the quote by hand in order to make it work.

Still no good OK in all my browsers, very nice!

  • OK: Firefox for Android 68.11.0
  • NG OK after clearing the cache: Vivaldi 3.7.2218.49 (Chromium 89.0.4389.91) (64 bits) on Windows 10
  • OK: Firefox 78.8.0esr (64 bits) on Linux (Debian 10)
  • OK: Chromium 88.0.4324.187 on Linux (Raspbian 10)
  • OK: Firefox 87.0 (64 bits) on Windows 10

In order of what I use the most often for MB on top.

Guess there was some old code still in browser cache. Deleting solved it ¯\_(ツ)_/¯

3 Likes

Vivaldi 3.5.2115.87 (Stable channel) (32-bit) working fine here on Win10.
Vivaldi 3.7.2218.49 (Stable channel) (32-bit) also Win10
Vivaldi 3.7.2218.49 (Stable channel) (64-bit)

(Handy - made me get round to updating to the 64-bit version)

2 Likes