Fingerprinting Notes


#1

I’ve read the documentation on this, and the forum thread from March that I almost necro’ed, but decided against, so… new post. And, while getting ready to post this, I finally figured out what was going on, but I’ll make a comment about future development. This is going to be stream of consciousness, so you can see the thought process of the new user trying to figure this out.

I tried scanning a file and nothing happened. Then I read more of the documentation, and found that I needed to have (fpcalc.exe) in the Picard folder. So I went and got it, latest and greatest, from the AcoustID web site. Then I saw there was already one there. I renamed the original and put in the new one in place.

Scan. nothing happens. Re-read the documentation. Oh, you need an API key. Get it from the AcoustID web site. Put it in.

Scan. nothing happens. Re-read the documentation, see nothing new. Come to the forums, see the thread from March. See the mention of the Activity log. Look in the activity log and it shows

21:37:42 AcoustID lookup returned no result for file

Dang… okay, so I need to upload it since the lookup failed [Yeah, I know, some of you are laughing at me now]. Submit is grayed out. Well it did a lookup, so it must have one. I see no way to tell one way or another in Picard if a file has a AcoustID tag. Scratch head, decide to reply to thread in Forums. Get the anti-necro warning and start a new post and start forming my thoughts and ask myself…

“Did you ever try the original fpcalc.exe with an API key loaded?” Then I answer myself, “Uh, no.” So, I put the original fpcalc.exe from the Picard distribution back and… voila, scan works, and now the Submit button is enabled. Ah ha… Picard doesn’t like the new fpcalc.exe, problem solved and I get ready to delete my new post. But then I think, maybe someone else is walking down this same dark path and I can help them, maybe a little. So I reorganize my thoughts (well, okay, I start the post a little different; you can’t call this organized.) and start typing a long winded post. Pages and pages, sorry.

I also think, well, what does it look like in the log with the right fpcalc.exe. Well… more like this:

21:48:20 Looking up the fingerprint for file…
21:48:21 File ‘…’ identified!

So, that means it found it. But did the message before mean that the AcoustID calculation failed, and not the lookup of the ID once it was generated? Apparently so. Maybe that wording could be tweaked to make it more obvious because running a hashing algorithm on a file is not doing a lookup, it’s computing a fingerprint. Asking a service if this fingerprint exists in a catalog, well, that’s doing a lookup. See, even the message at 21:48:20 called it one.

The Debugging log actually helped a bit clarify this, when I looked at it. A bit late. :blush:

Anyway, sorry for the rambling. The <TL;DR> (at the bottom, sorry) are:

  1. Read the documentation. Read it again. Let it soak in.
  2. Don’t replace the software provided until you’ve tried it properly.
  3. Words mean things. Sometimes they are used to mean things other than you think they mean.
  4. Eventually, Picard is awesome software and does what it says. You just need to work at it a while.

Thanks for your patience.


#2

Thank you.