File naming help!

Tags: #<Tag:0x00007fe3148da280> #<Tag:0x00007fe3148d9100>

HI! So I am very new to this, I’ve been looking into the documentation and community posts and tinkered with it for a few hours now and I just can’t come up with the desired results! Prior to this I’ve been manually fixing names and data for about 900+ songs with a few hundred more left :confused:

File Naming:
My music folder consists of 4 other folders separating music by language, I don’t want to create new folders for artists and albums. This is how I name my songs:
Title- Albumartist ft. Contributingartists (if any).

In the the filenaming option in picard, I can see the following:
Screenshot (5)

How do i fix this?

Edit: I’ve noticed another issue, in the music properties option, the contributing artists section lists all artists as one tag, instead of separating their names. Is it possible to fix this? If so how?

It seems like a very basic problem and I thought I’d have solved it by now. I’d appreciate the help!

Simply disable the setting Move files, then your files will just get renamed but stay in the same directory. The easiest way to achieve this is via menubar:

move-files

The tag %artist% contains all artists combined into a string with joinphrases (by default), what you want is the multi-value tag %artists% (notice the terminating s, this tag contains no joinphrases). You can overwrite this default value of a tag by going to Options > Scripting and creating a (new) taggerscript with the following lines:

$set(_artist_backup,%artist%)
$set(artist,%artists%)

The first line saves a copy of the original value as a (hidden) variable, else you can’t use this in your filenaming script anymore (see below for an adapted example).


By the way, if you want to hide the terminating hyphen for a single artist in your filenaming script, move it inside the if command:

%title%$if(%_multiartist%,- %_artist_backup%)
4 Likes