Error while setting up the project


1 Like

I confirm I ran into this issue.
The build system is looking for a file in /lobes/less/lobes/assets/ instead of /lobes/assets/.

I don’t have a good fix for it yet, but in the meantime, to allow you to move past the error, you can manually copy the file src/client/stylesheets/lobes/assets/background_tile.jpg into a new directory src/client/stylesheets/lobes/less/lobes/assets/. Note that the last two don’t exist yet in the less directory yet.

I’ll keep you updated when the issue is fixed

Confirm I’m also seeing this, but I seem to be able to run the site by doing a “build” followed by a “start”. Could it be something to do with whether we’re in “production” mode? If I get a bit of time today I’ll dig a little deeper.

I first saw the issue after the introduction of Typescript in the build. It might be worth checking out a commit before those PRs were merged to check.

Not sure how adding ts to webpack would be breaking less build, but it’s the only recent change to the build process.

It worked. Thanks @mr_monkey :slight_smile: