Error while setting up the bookbrainz database

I am new here . I am planning to contributing to bookbrainz . while database set-up ,
" ./scripts/" gives me this error.

Welcome @adk0971 !

Looks like a permission issue with Docker. It happens on unix machines !

First, make sure you followed the installation instructions for docker-compose, including the “Apply executable permissions to the binary” step.

If that’s all done, have a look at fix #2 on this page:

Let us know if you managed to run everything correctly.
Good luck !

1 Like

I am still not able to run docker commands without using sudo in this solution 2.

Maybe I’m missing something then.

Have a look at similar but a bit more detailed instructions:

You can first check if the previous command you tried worked as expected. Do you see your username when you run grep docker /etc/group?

Also make sure you’ve restarted docker (systemctl restart docker) or as a last resort, restart the computer and try again.

this command gives the following error
Failed to restart docker.service: Unit docker.service not found

this works fine. and returns docker:x:1001:adk0971

Did you try restarting the computer?

After that I must admit I’m out of ideas.
What’s your setup (OS, version, docker version)?

i restarted my computer . Seems it works.


Great to hear that ! :slight_smile:

1 Like