Error while setting up bookbrainz database with docker

Tags: #<Tag:0x00007fea47eee600>


Hi , i am new to bookbrainz and i am planning to contribute.
While setting up the database using docker-compose i am stuck here.
i’ve tried updating the my docker-compose and putting healthchecks in the docker-compose file still no luck.
can anyone please help ?

1 Like

Hi @Hatilar_420 and welcome !

We have a wait script that ensures the database is up before trying to set it up, and it looks like the database never starts in your case.

Can you tell me which command you are running? is it ./scripts/database-init-docker.sh?
Could you also please copy your docker-compose.yml file into a pastebin and paste the link here?

Hi @mr_monkey , Thanks for replying.

i am running ./scripts/database-init-docker.sh to setup my database
Here docker-compose.yml pastebin link. Changes can be found from line 34 to 38

i have made some changes to the docker file as it was showing error gpg: no valid OpenPGP data found while getting the postgres client key . To fix that i have to install the CA certs
Here is the docker file and the changes can be found on line 24 and 25

Also i have checked using docker ps the postgres service is running