Download and embed high-quality cover art only

Tags: #<Tag:0x00007f4d56a31a60> #<Tag:0x00007f4d56a31880>

Hi everyone - I have a pretty decent size mp3 collection of just under 22,000 songs. I wish Picard had existed years ago when I spent countless hours tagging all my music!

Back when I did that though, I had some low-quality artwork embedded into the mp3s (200-300px). I’m now using Plex for my music and the artwork looks like crap on the TV. I’d love to utilize Picard to help me upgrade the quality on all the artwork to better quality images (preferably 1200px or higher). I started doing it using Mp3tag but it’s extremely tedious because I spend too much time going through mismatched artwork that way.

Is there a way in Picard (on Windows) to bring in good cover art, replace the art on the mp3s, and not overwrite any other tags on the files?

I can’t answer your exact question, but https://beets.io/ would do what you want. The embed art plugin embeds as large an image as it can get unless you configure it otherwise.

I just switched to beets by making one tagging pass with Picard then importing them into beets since all the files would have track MBIDs already.

1 Like

After I wrote this answer I went and looked and Picard has an option on the Cover Art Archive screen for image size. It defaults to 500px but can do 1200px or even full resolution. You may not want full though; an I example I just looked at the full res one is 6.6MB and the 1200px one is 322 KB.

1 Like

I did run across beets right before finding Picard but thought it was only for Linux. I did find out how to install it on Windows since you mentioned it. I’ll check it out.

Thanks, @mtrolley - I already set the option in Picard to 1200px which would be perfect but it doesn’t seem to stick… it still keeps trying to bring in 300px artwork. Even if I can figure that out though, won’t Picard still try to update all my other tags as well (which I don’t want to do)? I’m sure I’m missing something stupid, but how do I just apply the cover art only?

I haven’t tried this but if you uncheck “Write tags to files” on the Tags settings but leave “Embed cover images into tags” checked on Cover Art settings does it work?

I’ve never had Picard download 300px images…I always had it set to 500px and that’s what it would get. Did you check the error log to see if it’s unable to download the higher resolution image?

1 Like

I added another cover art provider TheAudioDB and that is giving me some better results than the others so that’s a plus. Even though I have it set to 1200px, it’s giving me 700px for the Beastie Boys album I’m testing. Regardless, I’ll take that over the 200px image I currently have.

I just tried your recommended settings and it didn’t write to the file. :frowning:

So I turned back on “Write tags to files” and then did a CTRL+A on the tags in the bottom pane. I right-clicked and then chose “Use Original Values.” Then when I did the save and checked the file, the updated artwork is now there and it didn’t replace any of my existing tags.

The only downside is that it still added data for any instance I didn’t already have tagged. For instance, it added the MusicBrainz tags and filled in some other blanks. Small price to pay for the convenience though - I think that I’ll just do that for each album to make my way through it.

Thanks for your help, @mtrolley!

The Cover Art Archive settings only apply when downloading from the Cover Art Archive. TheAudioDB uses 700x700 for all its cover art. Another option is Fanart.tv, which uses 1000x1000 pixels.

1 Like