Do not match tracks with different length

Tags: #<Tag:0x00007f756e8814c8>

Hi,
I am I am new to picard, so maybe I am missing something obious. Picard keeps matching files with vastly different length if the rest of the tags match up. We are talking 15s or more. A difference like that would either mean a defective or different version of a song.

Is ther a way to control the automatic matching behavior? The only thing I could find was “Ignore track duration difference under this number of seconds” but this does either something different or is ignored. Maybe someone has an insight on what might be happening here?

Cheers,
Christian.

The length is considered during matching, but if there is no other better matching track it would still get used. But the track actually should get a bad matching score. If you want to exclude bad matches completely you could try to increase the thresholds for minimal similarity in Options > Advanced > Matching.

2 Likes

I have matching file to traks set to 88 and it still uses a track that has a 23s length difference.

So I am wondering if this ignore track duration does anything. The only thing I can see is that it turns the text brown but it will still match.

Are there advanced options hidden somewhere to configure the matching behavior?

I just tried Setting the percentage to 100 and matching an already matched song again. so the tags are identical but the length is obiously different. Even then it gets matched.