Discid missing on my Ubuntu 16.04

discid
Tags: #<Tag:0x00007f98ce99bad8>

#1

I’m a newbie with Picard and I want to work with music on a CD. I noticed that Lookup CD is greyed out. Help > About states that Discid is not installed. How do I get Discid installed on Ubuntu 16.04? BTW, I installed Picard using Flatpak.


#2

You can search for packages in a terminal on the command line with "apt-cache search package-name"

$ apt-cache search discid
abcde - A Better CD Encoder - Programm zum Kodieren von CDs
cd-discid - CDDB-Programm zur Ermittlung der DiscID
python-libdiscid-doc - libdiscid binding for Python (documentation)
isrcsubmit - extract ISRCs from audio CDs and submit them to MusicBrainz
libdiscid-dev - library for creating MusicBrainz DiscIDs (development files)
libdiscid-doc - library for creating MusicBrainz DiscIDs (documentation)
libdiscid0 - library for creating MusicBrainz DiscIDs
libmusicbrainz-discid-perl - Perl interface to the MusicBrainz libdiscid library
python-libdiscid - libdiscid binding for Python 2
python-libdiscid-dbg - libdiscid binding for Python (debug extension)
python3-libdiscid - libdiscid binding for Python 3
python3-libdiscid-dbg - libdiscid binding for Python 3 (debug extension)
python-cddb - Python-Schnittstelle für CD-IDs und FreeDB

You can get a full description with "apt-cache search package-name --full":

$ apt-cache search libdiscid0 --full
Package: libdiscid0
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 48
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Architecture: amd64
Multi-Arch: same
Source: libdiscid
Version: 0.6.1-0~ppa10-1~ubuntu16.04.1
Depends: libc6 (>= 2.14)
Suggests: libdiscid0-dbg (= 0.6.1-0~ppa10-1~ubuntu16.04.1)
Description-en: library for creating MusicBrainz DiscIDs
 libdiscid is a library for creating MusicBrainz DiscIDs from audio CDs.
 It reads a CD's table of contents (TOC) and generates an identifier which
 can be used to lookup the CD at MusicBrainz (http://musicbrainz.org).
 Additionally, it provides a submission URL for adding the DiscID to the
 database.
Description-md5: 5344ed68feeead8556eb80f81eafd6f0

You can install with "sudo apt install package-name":

$sudo apt install libdiscid0


#3

I don’t know about the Flatpak version, but it probably does not include libdiscid. Try installing Picard from PPA, this will use the libdiscid0 package as described above.


#4

Thanks for your responses. I determined the problem was with the Flatpak, so I removed it and reinstalled using the PPA. Now it works.


#5

Hi there, I maintain the Flatpak build of Picard over at Flathub.

Someone just mentioned this issue to me, so I fixed it and the update is currently building: https://flathub.org/builds/#/builders/2/builds/450

Give it an hour or so to land in the Flathub repo.

That being said, it would have been nice to come and report this issue over at Flathub, we could have fixed it 2 months ago. :slightly_smiling_face:

In the future, do report issues with the Flatpak build at https://github.com/flathub/org.musicbrainz.Picard/issues

Thanks!