"Delete listen" broken at the moment?

Hi all,

Is the “delete listen” button broken for everyone at the moment?
It’s there, but it doesn’t react to me clicking on it, and nothing happens.

(ListenBrainz → Listens → pick one, click three dots → delete listen)

I was hoping to tidy up a bit :slight_smile:

The button is working as advertised on my system. So I can’t confirm this behaviour. Just a shot in the dark: did you try it on a different browser? Sometimes switching the browser is all you need to get a specific function.

Thanks for checking. I’m glad it’s not broken for everyone else, at least!

I have tried in two browsers (Firefox and Chromium), and it’s the same for me in both. Hmm.

Hi! The Delete Listen button was indeed broken for a few days earlier this or in the past month. However, that’s no longer the case, can you check again if it works now or is still broken for you?

is still broken today the item is removed but any ctrl+f5 show it again

Hi! Delete listens is working afaik. But there is suboptimal UI around it currently. When you click delete listen, you’ll see the success message says the listen has been scheduled for deletion…The actual deletion usually happens within an hour. In that time, if you refresh the page the listen you deleted will still show up. Its a pending task to hide such listens on the frontend till those are finally deleted from the database.