Creating separate multiple genres — did I make a huge mistake?

I’m halfway through cleaning up my library and I’ve used multiple genre tags on many entries (like Blues, Piano Blues, Country Blues - because I want to be able to sort and search that way). But I just realized that all the players I’m testing the results on are treating my multiple tags as a single tag. So, my question: Can I fix this easily without having to go back through each album?

What I Did/My settings:

  • I used commas to separate multiple tags
  • I had the “Join multiple genres with a comma” field activated in Picard
  • I’m using ID3 v2.3
  • When I realized my tags were getting lumped, I changed the above-mentioned “join multiple” option to be blank. However, when I then tested more tagging this way, things didn’t seem to change (still getting the lumping effect)

I read one post about ID3v2.3 not working with multiple tags and then other posts saying it can be player-dependent and some don’t support it. So I’m confused. Can anyone set me on the right path and suggest an easy way to fix what feels like a big mess?

welcome to the community~

in my limited experience, most modern music players should be able to handle ID3v2.4, which does support multiple tags. I’ve only had a few edge cases where they don’t work

I’d recommend trying out v2.4 first, and see if that works in your particular setup


ID3 v2.4 is the one that correctly splits tags into multiple tags. This is why when you select it in Picard you see the “join multiple” flag disabled.

Older v2.3 could not do multiple tags so would have to find hacks to shove multiple tags into a single entry. A hack that then needed the players to read that same hack. Hence the older setting in Picard allowing you to pick a hack that matched your player.

Now v2.4 has the ability to write multiple tags that old hack is not needed.

Save a album with ID3 v2.4 tags and test all your players. As long as they can all handle ID3 v2.4 then go with it.

As to how to bulk covert - personally I’d use MP3TAG. You can set that to read the tags as they are now, but only save as ID3 v2.4. And you can work in huge bulk and quickly shift tag versions.

The trouble with doing this in Picard is it will want to update all your data at the same time which can be quite time consuming.


If you tagged your files using MusicBrainz Picard, and as long as you didn’t delete the MBID tags:

  • Change your Picard settings
  • Drag your music files back into Picard
  • Watch them get auto-matched*
  • Hit save

Always backup your library before making bulk changes.

*Depending on how many files you’re working with, go make a cup of coffee at this time. If you have a huge music library, drag in your music in parts instead :slight_smile:


Ahh, ok. Wish I had known about the differences before I started. But this is helpful to know and also thank you for the MP3TAG tip — sounds like it will save me lots of trouble. Really appreciate your help!

I think I will try some of my albums like this just to see what happens. I think the issue I might run into is that quite a few of my albums couldn’t get matched through the MusicBrainz database and so I had to supplement with my own or Discogs album art and info. So I’m thinking if I dump them back into Picard, I’ll run into the same non-recognition issue. Thank you for this advice — it’s helpful to know my options and to better understand this process!

1 Like

:crossed_fingers: :grinning: Hope this works!

Ok, so I switched to v2.4 and now get the little drop down menu for tags when there are multiple genres. I noticed that it separates the multiples with a semi colon. Previously I’ve been using a comma. Do you know if commas work as deliminators or should I be using semi colons when doing anything manually? (the drop-down menu doesn’t always appear).

I believe the semicolon isn’t actually written to the tags, it’s just showing where the tags are split. you can see this if you right-click the genre field and hitting “Edit…”

different media applications might show different seperators, and I believe Picard will also show seperate tags like on v2.3 when using the proper seperator (as set in options)