Crash with lyrics plugin on Windows 7

I’ve installed plugin but I can’t enter my API key since now Picard crashes every time I try to go to Options > Options… menu
Is there a way to fix this please ?
Thanks in advance

We need to figure out why Picard crashes. Can you give some more details, what operating system are you using, which version of Picard is installed, how have you installed it?

Two things to try:

  1. Try removing installed plugins and see if Picard starts then. You can remove plugins by moving them out of the plugin folder. The plugins are located next to the configuration file, see Picard won’t start — MusicBrainz Picard v2.6.3 documentation

  2. Try starting Picard from a command prompt / terminal. To do this on Windows open a command prompt and type:

"C:\Program Files\MusicBrainz Picard\picard.exe" -d

Make sure to include the quotation marks. Press enter. There should be some output on the command prompt just before Picard crashes. Paste that output or a screenshot of the command prompt here. If you have trouble getting the entire output ( the Windows command prompt can be a bit quirky to use) make sure to at least include the last part of the output, that’s the most interesting.

1 Like

I’m running version 2.6.3 on Windows 7, downloaded on Picard site.
I’ve tried removing just happydev lyrics plugin and it doesn’t crash anymore, thanks
Here’s the output related to the crash anyway:

W: 08:04:25,883 ui\theme.is_dark_theme:163: Failed reading AppsUseLightTheme fro
m registry
W: 08:04:25,887 ui\theme.is_dark_theme:163: Failed reading AppsUseLightTheme fro
m registry

1 Like

for more informations, my selected UI color theme was “Default”.
If I choose either Light or Dark, it’s not crashing anymore.
Probably a condition missing in checking AppsUseLightTheme

1 Like

Interesting, thanks a lot for the details. I don’t yet know how dark theme detection, Windows 7 and the happydev plugin are related, but this gives me some things to test. I’ll see if I can reproduce the issue and come up with a fix.

1 Like

I can’t reproduce this at all. Tried with a fresh install on Windows 7. Theme handling works as expected, the registry reading warning is expected on Win 7. Installed, but no crash.

Do you run Picard in a specific language? Sometimes issues with certain localizations can also be the cause for crashes.

1 Like