Could not load album - Plugin, SSL handshake, Network request error

Today when I tried to use MusicBrainz to name a CD I got an error: Could not load album

Here is the log. Would be great if anybody could help me with this:

I: 21:09:56 Plugin directory ‘C:\Julians Programme\MusicBrainz Picard\plugins’ doesn’t exist

E: 21:09:59 Network request error for SSL handshake failed (QT code 6, HTTP code None)

E: 21:09:59 Error loading plugins list: SSL handshake failed

What version of Picard are you using and on which operating system? From a first glance at the log info you provided, I would guess that you’re using an outdated version. If your version is less that v2.6 then I suggest that you update and try again. The latest version is available from the Picard Website.


Picard 1.x stopped working as it does not handle the newer SSL certificates used by the server.

As written above if possible update to the latest version of Picard.

The following thread also discusses the issue and provides a possible workaround for Picard 1.4:


I installed the new version of Picard today and now it works!

Thank you very much for your help!