Clean File Settings

I have lots of music files (about 5000). I recently downloaded MusicBrainz and followed a YouTube on how to use this tool.

I think it messed up a lot of the files, though.

My Foo Fighter’s Greatest Hits album is now tagged as being made by Tom Petty and the Heartbreakers from 1993. It set the Artist Id, the Recording Id, the Release Artist Id, the Release Grop Id, the Track Id, Genre, Media Type, etc. It is all wrong.

I have since seen others say they do their music in small batches so that they can correct anything that MusicBrains gets wrong. Well, that’s great, but it needs to say that when a Noobie like me comes in and loads it up for the first time.

What do I do now?

Do I now have to go in and clean every file in every folder? Is there a process in MusicBrains that I can use to go in and remove everything that it added and start over?

MB doesn’t know what it added. So there is no simple “undo”> And am guessing you don’t have backups?

Did you rename the files as well, or are the file names still intact? With a bit of work with MP3TAG you could use its Filename to Tags feature to copy data back across.

Though what is confusing is how you got something so different as Foo Fighters and Tom Petty mixed up. I would understand compilations got confused, but two different artists is certainly strange.

If part of the trouble is just that albums are jumping straight to the right, look into Picard’s settings / General and untick “Ignore MBIDs when loading new files” and tracks will stay on the left

4 Likes
  1. work on copies
  2. read documentation
  3. describe your workflow and ask here for help on proper setttings for your case
  4. that’s MusicBrainz, not MusicBrains
  5. “it messed up a lot of files” -> nope, you did.

Before pressing Save, ensure files are matched to the correct tracks.
I recommend you first search for the correct album, load it in Picard then move files to it. Don’t use AcoustID matching blindly and hope for the best, it will not work.

Picard is a complex program, to handle a rather complex process: tagging audio files with good metadata.

The learning curve is a bit steep, but it will do the job better than most programs around can do, once you get it right.

2 Likes

I’ve got to say, I am really having a hard time understanding what MusicBrainz is trying to tell me.

Like in the screenshot below, there is no save option after loading these files, and it’s telling me there are 13 unsaved files. Why isn’t the save option enabled? And why doesn’t clicking Save actually save all of the unsaved changes? How do I find what has or has not been changed?

And next, I get into the meat of one of these. I picked “Promo Only” because I only loaded up my AC/DC collection, and I don’t remember any promo CDs from AC/DC in my collection. As you can see from the details of it, it lists Madonna, Paula Abdule, Salt-N-Pepa, etc.

Obviously, I don’t want to save that! Is there a way to manually fix it? I can’t even tell what song each one is looking at. I’m really confused.

I don’t understand at all what you are trying to do in that screenshot.

Pick ONE album, then read the manual, work through the steps. Get used to it before you wade in with both feet. Learn with one album at a time, then ramp up to speed.

What do you mean “promo only”? Is that a setting you change somewhere? This could be why you are getting such crazy results if you are hitting random switches.

That YouTube video may have just been trolling you as they seem to have forgotten many steps. This is like a chainsaw - can cause a lot of damage if you just wade in without being careful. but one skilled you can create some neat results.

https://picard-docs.musicbrainz.org/v2.5/en/
https://picard-docs.musicbrainz.org/v2.5/en/workflows/workflows.html

You have @rdswift in that other thread… he literally “wrote the book” on how to do things… :wink:

All of us have been confused by Picard at times over the years, but you’ll soon get your head around the powerful tool it is.

3 Likes

I’m not sure what “promo only” means. I tried dropping all of my AC/DC albums into the Unclustered section, and that “promo only” just showed up.

I have to say, it does seem to work a lot better when I just to 1 album at a time. I have a lot of albums, though, and I was just hoping to be able to “set it and forget it” I guess.

Here’s what I’ve started today: Sometimes when using single albums, it will show 2 albums with the same name and (11/12) in the first and (1/12) in the other. I’m not sure what’s best here, but I’ve been dragging the isolated file in the (1/12) list up to the same album name in the (11/12) list and saving it.

Like, what does this mean?

Billy Idol: Rebel Yell has 3 folders: (2/9), (6/9), and (1/41)

It means Picard evaluated each track, and did it’s best to provide you with the best matches for each.

2+6+1=9

All you now have to do is drag the top release (containing 2), to the second release (containing 6, expecting 9), and drag the third release (containing 1) also to the second release.

Then just watch magic happen…

Honestly, I am still in awe of how well things like this work (since he who won’t be named again joined forces in the development of Picard)

1 Like

You are already pretty close. But as you see Picard now sometimes has distributed your files over multiple similar versions of a release.

That’s happening because you are either using the scan function (which looks at each file individually) or have lookup on individual files. In both cases Picard looks up file by file and tries to figure out for each file onto which release it thinks this fits best.

If you are looking up entire albums you should instead first use the “Cluster” button on the files you have loaded to the left (Unclustered files). Picard then tries to group those files into files that seem to belong to the same release. Picard calls this generically a “cluster”, meaning files belonging somehow together.

In your example that should result in a single cluster “Rebel Yell” with all 9 tracks. Once you have clustered the files you can then use “Lookup” on that cluster. Picard then looks for a best fit for the entire group, meaning it will search for a release “Rebel Yell” with 9 tracks.

Depending on what you are looking for and what files you are tagging and how the current metadata is you might still need to do Scan or Lookup on individual files. In those cases Picard might find the songs on different releases, including compilations. But you can always check the results and drag files around. You can also configure Picard to prefer albums over compilations or singles in Options > Metadata > Peferred > Releases.

You can also search the MusicBrainz database directly and load any release manually into Picard.

See the docs at https://picard-docs.musicbrainz.org/en/usage/retrieve.html on the various ways to load releases into Picard.

I think it is the name othat confused you. “Promo Only: Platinum Series” is a compilation, and it just happens to include one of the songs you were looking up.

My suspicion is that you used “Scan” for this all. “Scan” does an acoustic analysis of the files and tries to find a match. But acoustically there is no difference between that song on the album or on a compilation.

7 Likes

This group is helpful! I feel like I’m getting there.

Sometimes I get confused, though. Like I have [Monster Magnet] > [Greatest Hits]. Dropped the folder into Unclustered and let it work.

As shown below, at #1, track 1-09 maps to 2 different spots at #2, and both subitems are checked. I don’t know what that is trying to tell me.

Also, at #3, you can see 3 files 2-04, 2-05, and 2-06 are mapped over to #4 with 2-04 having a music icon while 2-05 and 2-06 have folder icons. What is this telling me?

Just to double check - are you:

  1. Dropping into unclustered/left hand panel
  2. Clicking ‘cluster’
  3. Selecting the resulting cluster and clicking ‘Lookup’

If so, great! Otherwise let us know, because that effects everything.


In your screenshot it matched two songs to ‘track 9 - bummer’. Before saving you need to click on each song (not the row with the note icon, the two rows under it), figure out which one is wrong, and then drag it onto the correct one. We’d have to see more info to know why it’s matched two songs/files to the same track.

Looking at the release, the two with folders icons are data tracks on an enhanced CD (video):


Your version of this release looks a bit weird tbh, I can’t match it with any of the Discogs versions either:
1 Like

The MB database is not perfect. So a few shuffles can make sense. Sometimes the AcoustIDs have errors or just too close to tell apart. A few drags are not usual. Just clicking on those two Bumper tracks will let you tell them apart and drag them to the correct matches.

As you click on each one in turn you will see their original name on the left hand pane.

The point is the Human Brain is always Superior to any Algorithm. Picard saves a HUGE amount of time once you get into the swing of it. Just need to learn to spot those Special Cases and fix the small number of hiccups :wink:

Looking at your Monster Magnet Greatest Hits album in your example is it a Real CD you ripped? Or sourced from “elsewhere”. Maybe the person putting it together added some extra tracks. There is certainly some odd numbering in that folder. MB will focus on Real releases and not the user created Torrented versions. Matching a Torrent sourced album can sometimes lead to having an album and a couple of singles in the same folder.

Got it.

Today, I am at my house trying to get MB to work on a few albums here.

For some reason, it isn’t loading the albums - any of them!

All the error says is the SSL handshake failed. I tried refreshing and even loading different versions of the album from the “Lookup in Browser” link.

Yes, my internet connection at home is garbage. The fastest I can get here is 780 KB/s. Is that what is causing this? Is there a setting I could change to fix it?

Is that an old version of Picard 32-bit? I think it has SSL issues and now in the “unsupported” bucket.

Can you try the 64-bit edition instead?

1 Like

Great idea. I’m not sure what version I am running at home. I’ll look into it. Thanks

I was on 1.4.2