Classical Extras 2.0

Ah, ok, thanks. I was confused by MetaTunes reply to you a bit further up noting that the error was introduced with v2.0.6.

Hi. I’m looking to use Classical Extras to add composition dates to my classical collection, but I can’t seem to use the work_year (from the Genre’s etc. tab under Periods and dates) in my scripts to add this to other fields. This is my first venture into scripting Picard, so it’s entirely possible that’s what’s not working; any input appreciated!

  # Year <- Classical Extras

This script does populate the MusicBrainz original recording date into the date field, so I know that’s working.

I believe that should work.
If you do a simple test using only this script:


And disable all other scripts and plugins, does it write the ‘atest’ tag properly?
And, did you make sure you are using Picard 2.1.3 or older?

Downgrading to 2.1.3 worked; hadn’t read back up the thread. Thanks.

I will try and find time later this month to update the plugin :sweat_smile:
Edit: failed in that objective as my new pc build went awry owing to a faulty graphics card. Hopefully will get that fixed shortly and start work on this in early January.

1 Like

Thanks for the update. Enjoy the December month without being distracted by computer graphics :wink:

Just starting to take a look again at the issue of Classical Extras not running properly under Picard 2.2.x, now that I have a working PC. On first inspection, it seems that most of the problems have gone away in Picard 2.3.0a1 - any clues @outsidecontext? I’ll look into it more fully next week. Until then, belated seasonal greetings to all Classical Extras users.

Hi, I’m new to Classical Extra and this is also my first post to this Community.
First of all many compliments for this plugin: I have some knowledge of programming and I can really appreciate all your effort and your passion.

I’m tagging some Karl Richter’s releases of Bach’s Canatatas, currently I’m on “Bach Cantatas Vol. 1: Avent und Weihnachten” (MBID 1746c566-3b05-4acb-a9e3-0b85dfbb81aa)

The problem is that I would get all the performers’ relationships with the standard names of their instrument, instead for some reasons I get only the credited name of the instrument. In example, I would get “performer: Karl Kolbinger (bassoon)” while I always get “performer: Karl Kolbinger (Fagott)”

I tried several combinations of CE parameters but no luck. Can you please point me on the right direction ?

That’s probably unrelated to the plugin. Have you checked Options > Metadata > Use standardized instrument and vocal credits ?

If not, check that option and try reloading the data.

I think it may be a plugin issue - I’m looking into it.

1 Like

On the “Artists” tab, in the “Other artist options” section, deselect the box labelled “Use ‘credited-as’ name for instrument” :wink:

1 Like

Of course! As usual I should read all the documentation, sorry.
Deselected “Use ‘credited-as’ name for instrument” and now it works, thanks

New (beta test) version 2.0.7 is now available at
This release fixes bugs encountered with Picard v2.2.x
It also has minor improvements and additional UI capability for adding any tag to the columns in the Picard rh panel (and flagging changed metadata).
Assuming no bugs creep out, it will form the basis of the next PR
Install by adding to your plugins folder. There is an extensive readme; please read this before raising queries. Post general queries in this thread.


Something seems wrong with ‘instruments’:
(the previous version displays ‘cello’ here)

Try this:

1 Like

That’s a Lucky Luke fix!

This release makes Picard close without any warning or error logged:

It happens every time after the countdown at the bottom reached 4.

Picard 2.3 Windows portable, Classic Extras all settings at default, no other plugins or scripts active.

Hmm. Brandenburg Concerto No. 3 is crashing it. I can see how, but not why. It doesn’t crash on my (Pinnock) copy. I’ll try and take a look this evening.

Hi @hiccup. I think the problem is caused by which is shown as a recording of two works - one being an arrangement of the other. I suspect that if this is fixed, it will process OK. I am assuming that the arrangement is the error and that link needs to be removed.
In the meantime, if you temporarily disable arrangements in Classical Extras (towards the bottom of the works and parts tab) and restart Picard, it should work.
However, I clearly need to do some error trapping for these instances.


Version 2.0.8 adds error handling - see
@hiccup - if you could let me know if that’s OK then I’ll do a PR for it.

1 Like