Classical Extras 2.0

That should be in my wheelhouse :wink:

I opened with notepad++, and there on line 3803 it only says: “for performer in performerList:”
No ‘True’ to be seen. Also not in a couple of lines above or below it.
Could you provide some more details where to find this?

About a possible implementation for this within the user-interface:
I am not sure if any additional setting setting would be necessary?

I personally would be happy if the hidden variables would always be available for scripting, irrespective of certain tabs activated, or checkboxes being checked or unchecked.

If I wouldn’t even want these variables available, I would just disable CE completely?

But there may very well be considerations that I am completely blind to.
I am not really in a position to give some solid suggestions here.

In PhpStorm that is line 3750 or 3797 (appears twice). So the line you want is either 6 lines below or 53 lines below (probably the former).

Re the UI or not, I guess you are saying put the alternative performer tags in as hidden variables. I might prefer to make it an option - I’ll think on it.

This is what I am looking at:

6 lines below it says:
if True and artist_type in [

So should I change that to:
if False and artist_type in [

If not, can you provide some specific strings that precede, succeed or surround this ‘True’ I should change to ‘False’?

That’s right. It’s a place holder for an option that never was. True would be multi-instrument, False is single instruments. (See the annotation a few lines below).

1 Like

I changed it to False.
Now retrieving the instruments variable also doesn’t work.
But it also is the time of the week that my brain is as reliable as the friend of the cousin of the half-brother of your uncle’s neighbour.


I gave it another try. I still don’t see any difference when using the edited True > False version.

With ‘Create extra artist metadata’ unchecked, CE does nothing, and instruments variables are not retrieved either.

With ‘Create extra artist metadata’ checked, instruments variables are retrieved, but CE will also alter the performers as shown in my earlier screenshot.

I’m not quite sure what your problem is. I have run it with “False” and it seems to give what I think you want. See attached screenshot.

Or maybe I misunderstand ?

1 Like

I think I found the cause.
In Picard I always have ‘Use standardised instrument and vocal credits’ checked, since I prefer to have the performers tagged and displayed like that.

That setting seems to causes the issue here.

I also tried several variations of settings in CE’s artists tab, but I while I can make it so that some performers get standardised, most others will still get removed:

Is there a way to make CE only make the instrument variables available for scripting, and ignores and doesn’t do anything with these performer tags? (and possibly other related tags I am not aware of)

I’m confused. I had ‘Use standardised instrument and vocal credits’ checked in my example. You can control what is used for the performer name in the ‘Work-artist / performer naming options’ panel in CE. Is the problem that you want the ‘standard instrument names’ in the performer credits, not the ‘credited as’ names.
If you give me an example of a specific track on the the release and what you expect to see, I might be able to help more.

That makes two of us :wink:

I noticed e.g. ‘Performer [batterie]’ in your screenshot, which made me think you had ‘Use standardised instrument and vocal credits’ unchecked.

While I think I already tried pretty much every possible setting in the ‘Work-artist…’ tab, I may give it some more and fresh testing tonight or tomorrow.

Thanks again.

I think the problem may be that CE is using the ‘credited-as’ instrument name in the performer tag regardless of choosing ‘standard MB names’ in both the performer and instrument options. Is that right? If so, it does look like it may be a bug that needs fixing.

That is how it seems to me at the moment.

Of course it may simply be that you have ‘Use “credited-as” name for instrument’ checked in the ‘Other artist options panel’. If so, please re-run without that checked and see what you get.

Now wouldn’t that be great. (and shameful)
But it’s not the case.

It is still weird (and slightly worrying to me) that you are not able to replicate this and it works fine for you.
I’ll keep investigating if there could be anything in play here that I am overlooking, but I am running out of ideas.

As I said earlier:

If you give me that and what you actually do see, I may stand a chance of tracking down the problem. Also post a screenshot of the CE artist options.

Is it possible this has diffused into two different matters?
Some ‘Lost in Translation’ going on perhaps?

The reason I brought this up (which I explained in my first post on this, #215) is that I am trying to only make use of the three different hidden ‘instruments’ variables that CE makes available.
I don’t want or need CE doing anything else than that.
(for this particular portable Picard installation that I use for non-classical music)

But now we are talking about if performers and their instruments turn out ‘as credited’ or not.

The available ‘instruments’ variables are already divided in ‘regular’, ‘credited’ and ‘all’.
And I am guessing no CE panel setting would affect what they each will display?

So if I am correct in that we are talking about two different (perhaps related) matters, here is a new start:

  1. Could it be made that ‘instruments’ variables are always available for scripting, even when all other features of CE are disabled.

  2. It seems like maybe there could be an issue with CE possibly not respecting ‘as credited’ preferences in certain circumstances.

(1.) Is my original request

(2.) Is something that never caused any issue for me personally. If you have a suspicion there is a possible issue or bug there that you would like to address, and you would appreciate me testing further and providing feedback on I will.

Not easily. If you disable all the features of CE then nothing happens :wink:

As far as I can see it is working properly and should give the same performer tags as vanilla Picard, provided the right options are selected. However, I would like to confirm that is the case. Hence my request for specific data to see exactly what you are getting, what is wrong, and what options you have selected.

1 Like

So the data that ‘_cea_ínstruments’, ‘_cea_instruments_credited’ and ‘_cea_instruments_all’ outputs will vary depending on specific settings within Classical Extras.

It solidifies the feeling I am punching above my weight here.
I am going to digest this new information and will report later, or maybe I will just give up on this.

As MetaTunes already said, having some concrete example would help a lot understanding the exact issue. When you are testing this, show us which release you used, how the instruments show up for you and how you would have expected them to be.

1 Like

Thanks the both of you for trying to help with this.
But it looks like I am incapable of bringing across what I am trying to achieve.
And/or I have a serious misunderstanding about the relation between these hidden variables and the regular performer/instrument tags.
The towel is in the ring.

I’m not renowned for throwing in the towel, so I’ll have another try.
Regardless of option choices:
_cea_instruments holds the standard MB instrument names
_cea_instruments_credited holds the credited instrument names
_cea_instruments_all holds them all

The instruments for each performer are the standard MB names if ‘Use “credited-as” name for instrument’ is not checked and is the credited-as name if it is checked.

All that is fairly obvious.

The tricky bit (that I think is causing your difficulty) is that, with certain settings, Picard will create one tag for each performer/instrument combination. CE does not do this - by default it will create instrument groupings resulting in a small number of tags. However, if you replace “True” by “False” as previously discussed, then it should separate the tags into single performer/instrument pairs.

So, AFAIK, to get the exact same performer tags as you were getting in “vanilla” Picard, you need to change “True” to “False” and uncheck ‘Use “credited-as” name for instrument’.

BTW, there is another hidden variable that might be helpful - _cea_performer_names_instrumented. This will list all the performers with their instruments (repeated if True changed to False and with standard MB names or credited-as names depending on the option choice).