Changes are not reflecting

I am trying to solve this issue - https://tickets.metabrainz.org/browse/BB-570.

As mentioned in the comment by @CatQuest , it can be solved by adding
overflow : auto ;

i did the same in style.less file

but changes are not reflecting.

i googled and tried doing CTRL+SHIFT+R for hard refresh , even tried in incognito mode but all efforts are in vain.
is it beacause i am changing style in the wrong file??Kindly instruct me.
below is my terminal output

Hi @adk0971,

To set up file watching, have a look at https://github.com/bookbrainz/bookbrainz-site#watch-files-and-live-reload and https://github.com/bookbrainz/bookbrainz-site/blob/master/NODEJS_SETUP.md/#Watch-files-and-live-reload-with-Webpack

2 Likes

I done the changes as mentioned in the live-loading documentaion.
i changed my docker-compose.yml in following way : -
bookbrainz-site:
command: npm run debug-watch-server
volumes:
- “./config/config.json:/home/bookbrainz/bookbrainz-site/config/config.json:ro”
- “./src:/home/bookbrainz/bookbrainz-site/src”

postgres:
volumes:
- postgres-data:/var/lib/postgresql/data
- “./src:/home/bookbrainz/bookbrainz-site/src”
elasticsearch:
volumes:
- elasticsearch-data:/usr/share/elasticsearch/data
- “./src:/home/bookbrainz/bookbrainz-site/src”

redis:
command: npm run debug-watch-server

kindly anyone from the community please verify that about the changes i had done.

Apart from a couple of things, this looks all right to me:

  • The redis command in docker-compose.yml shouldn’t be changed
  • You don’t need to mount the source folder (./src:/home/bookbrainz/…) as a volume for postgres or elasticsearch services; you only need it for the bookbrainz-site service

And you should be all set !

2 Likes

i did a big blunder by doing this.
and now

even i restarted my laptop and changed to default redis command.

solved! :slight_smile:
just stopped the dependencies and rerun the ./develop.sh
it worked.

1 Like