CD unit path on OS X

macosx
help
picard
Tags: #<Tag:0x00007f23c0c69270> #<Tag:0x00007f23c0c69130> #<Tag:0x00007f23c0c68ff0>

#1

Hello,
I’m always trying to learn more about this great software, but I have a problem I can not solve.
I can not set the correct drive path cd in the options.
I’m on OS X Yosemite and to know what is the volume I gave the terminal mount command, this is the result:

iMac-di-Alessio:~ Alessio$ mount
/dev/disk0s2 on / (hfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, nobrowse)
/dev/disk1s2 on /Volumes/TM (hfs, local, nodev, nosuid, journaled)
/dev/disk2 on /Volumes/CD Audio (cddafs, local, nodev, nosuid, read-only, noowners)

Then the path would be ‘/dev/disk2’ but when I select lookup CD tells me I can not open ‘/dev/disk2’.
How can I do?

Thank you.


#2

Welcome to MusicBrainz, Alessio!

Try /dev/rdisk2 and see if that works. Note the extra r. It means “removable”.

Does that work for you?


#3

Unfortunately, I get the same error :smirk:


#4

If you are talking about reading DiscIDs in Picard, try clearing the line that has the device name in the preferences. It is my understanding that setting a device there will cause Picard to try to use that instead of defaulting to letting it pick the CD automatically.


#5

Yes, that should do the trick. The issue here is that on OSX the device names are not stable and can change. So on OSX it is probably best to keep this empty and have it automatically detect the device.

I have never tried it, but you should also be able to enter just a drive number, the default being 1. That way you can specify which drive to use if you have multiple CD/DVD drives. That might need some experimenting, but if you have two drives and Picard uses the wrong one by default just try entering 2 into that field.


#6

I tried leaving it blank, but the icon of the CD lookup is inactive, I also tried inserting 1 and 2 but still get the same error.
I only have the built-in player in the iMac.
There is no way to solve?
Thank you


#7

Indeed, the icon gets disabled. We shouldn’t do this on OSX I think. Can you tell me what version for Picard and libdiscid the About dialog is showing? Also you could test whether the number trick works in the 1.4 development version available from the download page


#8

The version of Picard is the 1.2 but how do I know which version I have of libdiscid?

I can install the 1.4 to 1.2 at the same time?


#9

In Picard 1.2 the version of libdiscid is not shown.

I am not sure if this is possible easily on OSX. But you really shouldn’t use 1.2 anymore. You really should use at least Picard 1.3.2, the latest stable version. I am not entirely sure, but the numbering trick could work there (if the bundled libdiscid is new enough). If not try it with the 1.4 dev version, it is usually stable enough for daily work, but it can happen that something is broken.


#10

I installed 1.3 and now everything works.

Thank you!


#11

It’s easy to have both versions installed on OS X, but Picard sets a flag in it’s preferences that can make it awkward in using long term.