Can't tag performers on a single release

I’ve been using Picard to update the performer tags (among other things) and I’ve come across one album that stubbornly refuses to get performers. The release is Money Jungle by Duke Ellington:

Performer credits were already partially entered, and I added the missing ones. Picard has matched it to the correct version. I have both “use track relationships” and “use release relationships” checked in Options. But no matter how many times I ‘Refresh’, the performer tags are missing.

Looking in the debug log, I see that it’s retrieving performer credits:

…which, when opened in a browser, shows me 'relation type=“instrument” ’ nodes at the track level. But nothing shows in Picard:

Any suggestions where to look next?

Just taking a shot in the dark, but have a look under Options -> Metadata and see that you have the “Use release relationships” and “Use track relationships” options checked. If they’re already checked, then I don’t know what to suggest.

1 Like

Yep, both are checked, I’m afraid.

Mystery solved - apparently I ripped this CD as MP4 (.m4a) files, although almost all my rips are MP3. As documented in the tag reference, there’s no mapping for performer into MP4 tags. I guess I will go back and re-rip.