Can't convert 'bytes' object to str implicitly


#1

Hi,
I am using MusicBrainz Picard to divide a large list of files into subdirectories.
It has worked for 5900 files perfectly, but for 700 of them I am getting the following error:
“error:Can’t convert ‘bytes’ object to str implicitly”
Anybody know why I am getting this, the files seem to be the same as the other files I have successfully assigned to subdirectories.
Thanks,
Dubliner.


#2

Hi, We need some more info for this. Can you take a look at Help > View Error/Debug log when this happens and post the output here? Also the file format could be important.

EDIT: And please let us know your operating system :slight_smile:


#3

Hi, I get the exact same error, so maybe my info will help you:
OS: Win10
Format: .aif
error code:
E: 00:40:25,311 util.thread.run:51: Traceback (most recent call last):

File "picard\util\thread.py", line 47, in run

File "picard\file.py", line 210, in _save_and_rename

File "picard\formats\id3.py", line 346, in _save

File "picard\formats\id3.py", line 346, in <listcomp>

TypeError: Can’t convert ‘bytes’ object to str implicitly


#4

Thanks a lot, that helps us identify the issue. Should be possible to fix this in the next release

UPDATE: A fix is ready for the next release. Some background: This happens to files which include an iTunNORM tag, which iTunes writes for audio normalization. This is a regression in Picard 2


#5

Ok cool, thank you! Any hint on when we can expect the next update?