Cannot tag a standalone recording

I’ve bought a single track on the Internet, added the details to MusicBrainz

Name: Made in Paris
MBID: c86d5d86-0bb1-4c22-9e03-7057f933470d
Last updated: 26/10/2019 12:35
Permanent link:

but can’t figure out how to tag the flac file.
I do a ‘Lookup in Browser’, it finds the above recording, but when I click on the green tag, nothing happens.

As an alternative to the green tagger button you can also drag the URL to the recording from the browser’s address field onto the Picard window or copy and paste it into Picard’s search field.

In regards of the green tagger button you need to be aware of a few things. First it’s important that you start “Lookup in browser” from one window of Picard you don’t open a second Picard window and expect the results there. The magic is actually the port number you see on the bottom right of the Picard window:


If you look into the URL opened in your browser you will see that same number added as parameter, e.g. tport=8010.


That way the website knows how to locally connect to your running Picard.

Now if that is all looking good there can be other reasons this does not work, e.g. some security related browser extensions might block the access here. To find out more you could look into both the Picard debug log (Help > Show Error / Debug log) and into the debug console of your browser (in Google Chrome and Firefox you can open that by pressing Ctrl+Shift+I). Also just trying it with a different browser can help.


Oh, just realized this does not work :frowning: It works for releases but not recordings. I’ll make sure we fix this.
UPDATE: This will be fixed with the next release

But drag and dropping the URL works.


Dragging the URL into picard results in the following error.

E: 09:56:58,384 /usr/lib/picard/picard/browser/browser._process_request:124: ‘utf-8’ codec can’t decode byte 0xfc in position 8: invalid start byte

One thing I noticed, though, is the when click on the Overview tab on MusikBrainz for the recording I get the following message

No releases found which feature this recording.


What version of Picard are you using? And which URL are you actually dragging?

That’s because this is a pure standalone-recording, it is not included in any release.


The Picards Version is 2.1.3

I turned debuggin on and get the following
When I drag the Green Arrow, I get

D: 10:31:24,677 /usr/lib/picard/picard/ui/itemviews.dropMimeData:548: Drop target = None
D: 10:31:24,681 /usr/lib/picard/picard/ui/itemviews.drop_urls:511: Dropped the URL: ''

when I drag

into Picard I get

D: 10:28:24,875 /usr/lib/picard/picard/webservice/ratecontrol.get_delay_to_next_request:114: ('', 443): Last request was 25984 ms ago, starting another one
D: 10:28:24,876 /usr/lib/picard/picard/webservice/ratecontrol.increment_requests:134: ('', 443): Incrementing requests to: 1
D: 10:28:25,185 /usr/lib/picard/picard/webservice/ratecontrol.decrement_requests:142: ('', 443): Decrementing requests to: 0
D: 10:28:25,186 /usr/lib/picard/picard/webservice/__init__._handle_reply:411: Received reply for HTTP 200 (OK) 
D: 10:28:25,188 /usr/lib/picard/picard/webservice/ratecontrol._out_of_backoff:225: ('', 443): oobackoff; delay: 1000ms -> 1000ms; slow start; window size 4.000 -> 5.000


Yes, dragging the tagger button is not supposed to work, you need to drag the recording URL as in your second example. And according to the logs it worked and it loaded the recording.

1 Like

Ok. So for the url that works, it updates the track details, but I can’t save the result; there is no option to save this.

If you just have the data loaded from MB there is nothing to save. You need to load your actual file into Picard and match it there.

So what you probably see is this:


The musical note indicates that this is just the track data loaded, but there is no file to save.

You have to load your file into Picard and then you can drag it to the recording loaded on the right:




Thanks for your help, all ok now

1 Like