Cannot save tagged files

I’ve completed tagging all the folders and files that I loaded into Picard. They are all sitting in the right pane, with rectangles next to most of them. The left pane shows 0 Clusters and 0 Unclustered files, since everything has been moved to the right pane.

Then I select everything in the right pane and click the Save button, and all the rectangles next to the files in the right pane change into red dots with a white dash in the middle. No check marks next to the files. And the files do not save, no matter where I set the destination folder. I haven’t seen that anyone else has had this problem.

Is this a problem with the settings on my computer, or am I not doing something totally obvious in my Picard settings? Options have Rename Files, Move Files, and Save Tags checked. Under Options in File Naming, Files Like This is %artist%/%date%/%album%/%artist% - %title%. Under Fingerprinting, Use AcousticID is checked, Ignore existing AcousticID fingerprints in unchecked, fpcalc.exe is in the correct folder, and there is an API key.

Under Plugins, Last.fm and Last.fm.ng are the only ones checked. And under Scripting is $set(date,$left(%date%,4)).

What to do to get Picard to save my work? Thanks.

1 Like

Do you see any error messages when you go to “Help” -> “View Error/Debug Log”? That might help identify what is failing.

Also, what type of files? Also check t confirm that the destination directory isn’t write protected.

3 Likes

Check that your files are not set to ReadOnly and you can write to the destination location you are moving the files to.

1 Like

Thanks for your responses. I went to one of my source folders and the read only attribute was selected. I un-selected it, clicked apply and OK, and all the sub-folders and files zoomed by one-by-one. Then clicked OK again and closed the source folder. But when I checked its properties again, read only was once again selected.

1 Like

Yeah - that quirk sometimes happens, but now it is a grey tick on the folder. Go and check the files separately and you’ll see they all have that read only flag cleared correctly. :slight_smile:

Thanks so much. It’s now saving.

1 Like