Anyone Try Picard 2.2 on Mac OS 10.11.6?

Tags: #<Tag:0x00007f7569855e18> #<Tag:0x00007f7569855d28>

I am on Mac OS 10.11.6, and whenever I launch Picard, it keeps reminding me that there is an update available. Now, I did not update when 2.2 came out, because the requirements say 10.12+. The question I have, is, what could it hurt to update to 2.2.2? I do not like using outdated software, but I also am aware my iMac cannot be upgraded past 10.11.6. Would anyone recommend I try the new Picard anyway?
Thank you!

1 Like

Actually we got feedback that the 2.2 release does not launch on macOS before 10.12, and since Picard 2.2.2 the app is marked as requiring at least 10.12. If you try to launch this on earlier versions macOS will show you a dialog that this is not possible.

We had to raise the minimum required version because we upgraded the Qt toolkit to fix a number of bugs, and the newer Qt versions have 10.12 as minimum supported version.

Because of this we will continue to provide a download link for the 2.1.3 version on https://picard.musicbrainz.org/downloads/ . But supporting macOS before 10.12 with newer Picard releases unfortunately is not feasible for us.

3 Likes

Thank you very much, outsidecontext, for your response and for making it possible for me and/or anyone else to understand.

One day, I will get that new iMac… :nerd_face:

You have a great day!

1 Like