Anyone else experiencing problems saving after lookup?


#1

Anyone else experiencing problems saving after lookup?
I can cluster files correctly, can lookup, but cannot save the information.

Any ideas?
A known error, am I doing something wrong and where could that be?

Any help appreciated!


#2

Hi,

A couple questions:

  1. is this all files, or only some?
  2. have you double-checked that you have write permission for these files?

It would help to know in more detail what you do, and what happens (or doesn’t happen) when you do it. A screenshot might help too.


#3

Hello, and thank you for responding so fast!

As for your questions, yes this applies to all my files.
These happen to be on a Synology NAS which is up to date.
MP is on a Macbook with Sierra.

I checked the file permissions and accoring to the mac, everyone can read write.

What happens in Picard is that saving even of a single cluster after looking up means ‘not responding’ and I have to force quit.

Hope this helps a bit in describing the situation.
I only have tablet now, so would have to make a screenshot later if necessary.

Thanks,

Wim


#4

Don’t force quit it, wait :slight_smile: It is a known issue that the Picard UI sometimes can become unresponsive when saving large files to slow storage. Try to save only a few files and give it some time to see if it writes them.

Are you saving lossless files here, e.g. FLAC?


#5

OK, I’ll wait longer.
Indeed, I am working with FLAC files on the NAS (but also with MP3).
I’ll report back!


#6

Mmmmm…

I am waiting 15 minutes on a 6 track FLAC rip of a CD now.
Never had to wait, let alone for so long.

Could this be OSX Sierra related?


#7

It could be a multitude of things. It could be less-than-optimal implementation of Samba (or whatever network file system is being using for the NAS). It could be a spotty network (is your machine or the NAS connected wirelessly? Would it be possible to try and wire them up and see if that helps?). In fact, I don’t know how well Picard handles writing to a network file system in case the network is dropping packages etc. Do you know what OS the NAS is running and what the file system is on the NAS? Some versions of Linux have really poor NTFS performance, so if the NAS is using a “bad” Linux kernel and is writing to an NTFS filesystem locally, that could also slow things down.


#8

I have this same issue. Mac OS X Sierra, and I’m using a Synology NAS, where I’m reading various formats of music files and trying to save them to a different directory in the NAS. I definitely have user read/write permissions set up properly on the NAS.

The NAS is mounted via afp (Apple Filing Protocol) as per Synology instructions.

Saving 1 file at a time seems to work

Saving a single album together, or group of files, causes the program to hang, and causes my CPU to spike above 50% activity. I’ve force quit before, I’m currently trying to save 10 files at once, and it’s hanging.

I will post back if I figure anything out.
I may try mounting via SMB2 or Samba next, instead of AFP, if that’s supported. We’ll see.
Failing that, I’ll move the untagged files from my NAS to a local drive, or even a USB drive, and try again that way.


#9

I didn’t really bother with the remounting - I just copied music files from the NAS to a USB drive, and tried again from there. Picard is working as expected. It must be something about the NAS delay, or even a synology NAS file system peculiarity.

So… I’m not going to bother troubleshooting further. I would suggest not trying to run Picard while reading from a NAS and writing to a NAS.


#10

Ah okay! Let me see if I can replicate that and see what Picard does when saving to USB or harddisk.

My setup is alike; afp mounted Synology running latest Synology software. That setup has worked fine, so if no one is experiecing Sierra problems the NAS upgrade might be the likely candidate.

Onward to the testing, to be continued when I am home in a couple of days.


split this topic #11

2 posts were split to a new topic: Forbidden signs when saving files