Alternative characters inside tags


I recently tagged a lot of albums and, upon playing then on my phone I noticed something: Some characters are not displayed correctly on my Pebble watch.

I know that the Pebble smartwatch has a very limited character list, but I didn’t have this problem before. Upon searching inside the tags, I noticed that some punctuation characters were different than the usual (meaning what I would get from a normal US or German keyboard.)
For example the usual dot (full stop) is replaced by the one dot leader (Unicode Lookup: convert special characters). The problem doesn’t seem to be limited to my ancient smartwatch, but not even Notepad++ on Windows 10 cannot display it.

I am using Picard v2.8.5 (seems to be the latest portable version). “Convert Unicode punctuation character to ASCII” option is checked. Is there any other setting I should change in order to revert to “normal” punctuation characters?


PS: I have no problem if certain punctuation is converted to underscore in the filenames as long as the tags are correct.

Actually " Convert Unicode punctuation characters to ASCII" is supposed to handle exactly this case.

Maybe it is not concerting certains characters? Can you share a release on MusicBrainz for which you have this issue?

1 Like

I just checked the Picard source code and it indeed does not concert the ONE DOT LEADER to a ASCII dot, but probably could and should do this.

On the other hand I suspect that the use of that character in the MB metadata is probably an error and should not be the case. But for that we will need to see the concrete example.

If you want to replace this character in a tag you could also do this with a script. E.g. the following script will replace it with a dot in the artist and title tag:

1 Like

This is one of the tracks creating me problems: Release “Fall, I Will Follow” by Lacrimas Profundere - MusicBrainz

Ok, that’s a bit odd actually. The dots used in this track’s title (and also the next track “… and Her Enigma”) are actually just ordinary ASCII dots. Nothing special.

Furthermore if there would be a ONE DOT LEADER or a TWO DOT LEADER it would be replaced by the ASCII conversion option to a single ASCII dot or two ASCII dots. I just checked this works. It is not specified in the conversion mapping Picard applies but it is done as normal Unicode normalization, so my comment from above is not correct.

So I’m not sure what’s happening in your case. The characters in MB database are only dots, and even if they weren’t the option you enabled would convert them. Maybe these are just the existing tags already in the files? Have you actually matched the files to the above release in Picard’s right pane before saving?

If yes, do you maybe have some tagger script enabled in Options > Scripts? Or maybe you have matched the files but have set the title tags to be preserved in Options > Tags?


Found the culprit: Replace Forbidden Symbols plugin!
Damn! Thank you and sorry for wasting your time!
Have a great day!


Oh yes, I didn’t think about this one. Great you found it.

Just some note about this functionality, as this plugin primarily tries to solve the problem with incompatible characters in filenames: Since Picard 9 you can define custom replacement characters for each of the symbols that are forbidden in Windows filenames in Options> File naming > Compatibility (see the documentation).

This applies then only to filenames, so it does not mess with the tags in the files. I think this makes the plugin mostly obsolete.

1 Like