All tracks are assigned the album title

I’m new to MusicBrainz Picard and have already tagged several albums successfully.
I have encountered a problem with an album where track 4 has the sme name as the album name.
It seems to have performed the lookup correctly but after saving
It has assigned the album name to all the tracks.
Sorry if the titles are in French.

I don’t understand the second screenshot.

Thanks in advance.


The problem seems to be that ALL the MP3 files have attached themselves to track 4. You need to manually drag each track to match 01,02,03,05,06, etc so you get a TICK for each one instead of the music notes.

The problem here is because your music files seem to be starting with the album name in all the file names and Picard doesn’t know how to match correctly. So Picard thinks they are all track 04 as it just sees the name of the fourth track ten times.


I think second screenshot is of the windows directory view of the files with a number of properties showing for each of the mp3 files. Ignoring the first file ( see below), it shows the Title of all the files to be the same, the title of track 4. This is why Picard is grouping them altogether as @IvanDobsky has identified. Manually removing them in windows (right click on each file and edit properties) or in Picard as suggested will fix it.

The first file is long and probably contains the entire album. Might be simpler to move it to a separate folder(directory)


@dpr :The windows directory screenshot is the result of the save in Picard that shows it has named all the tracks with the album title. The long file is the unsplit album. It wasn’t loaded into Picard but true, it would be better to move it esewhere…

@IvanDobsky : “You need to manually drag each track to match 01,02,03,05,06…” . Sorry, not sure what you mean. Could you explain? The unticked tracks already have track numbers.

What do the mp3 files look like before loading into Picard? Do they have separate titles and track numbers?

Drag all tracks 01 to 10 onto the LEFT hand side and cluster.

Now manually drag track 01 to track 01 on the right, then 02 to 02 on the right and so on. One by one until you get all separate ticks.

Currently picard cannot make sense of them due to how the the files are named. Picard just reads “Sarnedi soir sur la Terre” ten times and attaches all ten MP3s to track 04. You have to fix this as a human.

Tracks before Picard:

Drag all tracks 01 to 10 onto the LEFT hand side and cluster.
Now manually drag track 01 to track 01 on the right, then 02 to 02 on the right and so on. One by one until you get all separate ticks.
Picard cannot make sense of them due to how they are currently named.

Ok, I’ll try that.


You can also do the dragging around on the right hand side as shown in first your screenshot. Just easier to do when the files are still on the left as you can more easier read the original file names.

I don’t know what is happening now but if I drag the files from the windows folder to the left pane in Picard they automatically get moved to the right hand pane.

Windows folder:

After dragging files to LEFT pane in Picard:

In the “General Options” page in the “Options…” window, you can disable this action by enabling the Ignore MBIDs when loading new files setting. See the Picard User Guide for more information. Alternately, you could just drag all the incorrectly matched files back to the “Clustering” pane or directly to the correct track in the “Albums” pane.

The music symbol beside the track names means that there are no files matched to that track, or there are more than one file matched to the track. See the Status Icons page for more information.


You can still pick hold of any single item in the right pane and drag it to the correct place. Look at the lower pane and check the filenames in the status bar at the very bottom.

What I don’t understand is that, after doing a lookup, the tracks that have the music symbol have track titles correctly assigned:

The ones with the green rectangles all have the album title.

I can’t move tracks from the left pane to the right and I can’t get it to put ticks against the tracks so it on’t save anything.

Hard to show, but shuffle the MP3s you have attached to track 4. Drag one at a time to fit in the correct order.

The trouble is the ONLY data you have to work on is the filename and the track lengths. This is why Picard can’t do it for you.

1 Like

Ah I see what you mean. I’ll give it a try tomorrow. It’s late here!
Thanks for your help on this.

For tomorrow morning :blush:

drag and drop


Moving the tracks as shown by @IvanDobsky and @aerozol has solved the problem.
Thanks very much!