Albums continually load

Tags: #<Tag:0x00007f05094a28c8>


Hi: I’ve added my whole music folder to MusicBrainz and I’m going through album one by one looking up the information. But I’m noticing that, in the background, it’s looking up album information almost automatically and putting albums in the pane on the right side of the screen. I’d really like to do this manually so that I can keep control of the process. Is there a way I can stop Picard from doing this automatically?


If you had files previously tagged with MusicBrainz and they contain the MusicBrainz IDs for release and track Picard will automatically load the corresponding release. This allows you to easily update files previously tagged without going through the whole matching/lookup procedure again. You can turn this off in the general options by checking “Ignore MBIDs when loading new files”

But since you are going through the albums one by one anyway, why not load only a couple of files at once?