Album tag not being saved on first pass


#1

Long-time user of Picard here. I have been facing this problem past month or so. I would drag the files into Picard, save the findings and then clear from Picard. When I check the file in Windows Explorer or my music player, MusicBee, the album tags are not visible. Then when I drag the file again into Picard, the file go into the right panel with the previous search results matching. I “save” again and the album is stored in this second pass in the file.

Please help.


#2

Sounds like a refresh issue. Have you tried rescanning the files in MusicBee after the first save?

While I would expect it to show up in Explorer properties, I can think of scenarios where it would appear to have not changed.

Have you tried a third party tool such as "MP3Tag?


#3

I don’t want to use other app. I want to use Picard only.

The problem remains exactly how I have mentioned in the OP.


#4

I was suggesting that you check with a third party app, such as MP3Tag to assist you with your troubleshooting.

Having the files show up in the right pane the second time they are brought into Picard is evidence that the tags are being written to the file properly. The fact that they are not showing up in other applications suggests that the other applications are relying on cached data to display tags. Either “Rescan” the files in MusicBee, or restart MusicBee altogether before checking.