Add dropdown not working and not able to add entities

I was trying to add some entity to my localhost. So after starting the server --> Add --> author

Even after filling out all the details Submit button is still unresponsive. And when I again click on the ‘Add’ button dropdown doesn’t work, and url changes to-

http://localhost:9099/author/create#

An extra ‘#’ appears in the url.

Console is showing a warning which I don’t know from where arised because I haven’t changed anything in the code. There’s nothing changed in the Version Control

Need help! :upside_down_face:

When dropdown buttons don’t work, in my experience, it’s because the client-side javascript files haven’t been compiled properly, or that you tried accessing the page before the end of the compilation.
Try waiting a bit and reloading the page?

I tried that but the problem still exist. Anything you can suggest?

Without seeing more logs it’ll be difficult.
Can you please send a pastebin of the full logs for the server side and the browser side?

Browser side log:
https://pastebin.com/bBLP6BJw

Server side log:
https://pastebin.com/LyySZp48

I guess there is a problem from the client side probably in entity-editor.js

Yes, it looks like it.
It’s a good exercise for you to try to find out what happened. You can use your browser’s developer console to debug it.
Find the piece of code that’s throwing the error, put a breakpoint, and inspect the code to see what’s happening.

If you use chrome, here’s a how-to: https://developers.google.com/web/tools/chrome-devtools/javascript/

2 Likes

I will try to debug it and get back to you. Thanks a lot!

1 Like