ACOUSTID_ID metadata padding

Is it by design that the ‘acoustid_id’ metadata has all that non-removable padding at the end of it?

The ‘–dont-use-padding’ option in metaflac.exe doesn’t remove it.


Can you be a bit more specific which padding you mean and how the data looks like? The value of “acoustid_id” is supposed to be a single string with a UUID like " 5b619b5f-640a-4cc7-b44b-642778218bc2".

Yes it looks like that… and adds LOTS of nul chars after it. Like a normal padded flac would be. The --dont-add-padding option in metaflac.exe has been removing all the NULs in the tag area, but the paddding for acoustid_id appears to be added with that tag only (like it’s part of the ID). I can remove that tag and it removes the padding.

What software are you using to write the tag? Can you share the output of metaflac or a hex dump of the tag block (or a screenshot from a hex editor)?

metaflac.exe is included with flac.exe directly from the source…

The following is simply from notepad… notice the emptyness… that is padding from the ACOUSTID_ID tag.

I think you are missing some attachment in your last post. Please share the output of metaflac --list "yourfile.flac"

notepad is really not a good tool to inspect the binary structure of a file. If you want to see actual byte content use a hex editor.

There is generally not supposed to be any extra “padding” just behind the acoustid_id tag. If you have a file which has some extra spacing after the actual content I’d recommend loading the file into Picard or another tag editor, clear any extra whitespace that might be at the end of the tag and resave it.

If you actually mean the general PADDING block that is usually present in FLAC files after the VORBIS_COMMENT or PICTURE block then this is something different. I don’t recommend it, but you can remove it with metaflac:

metaflac --remove --block-type=PADDING --dont-use-padding "yourfile.flac"

The reasons that you need to specify both --remove --block-type=PADDING and --dont-use-padding is that by default metaflac with the --remove option will replace the removed blocks with a PADDING block for future reuse. Removing a PADDING block without --dont-use-padding hence has no effect.


No go… ERROR (–block-type): malformed block type specification “padding”.
Out of the fields I use, ACOUSTID_ID is the only one that has padding.

Thanks though.

Sorry, I can’t help you without actually seeing what you mean.

Regarding the error in metaflac you probably typed “padding” (lowercase) instead of “PADDING”. This might be case sensitive.

Thanks for your help. It is case sensitive and for what I am doing metaflac.exe must be run twice to work (easy script).

metaflac --remove-all-tags-except=ACOUSTID_ID=ARTIST=TITLE %1
metaflac --dont-use-padding --remove --block-type=PADDING %1

Thanks again!