AAC files and album information



I have convert lot’s of files from FLAC to AAC (M4A) so I can listen to my music in the car. The problem is that all my converted files have no information at all so all music is a folder called “other” in my car. I pick up my files in VLC player and there are the same problem there, no information at all(artist, album, title).

I try to fix this problem in MusicBrainz Picard but it still not work. As you can see in the picture I attach all of my files is still unmatched for some reason. I have followed this guide: http://picard.musicbrainz.org/docs/guide/

What am I doing wrong???


The red stop sign is a bit weird, it indicates that there’s something wrong with the files, eg they’re set to read-only or similar.
Have you tried dragging the files from ‘unmatched’ to the correct track above it in Picard?
Does that work?


As aerozol said, that red sign indicates there was some error with the files. please look at Help -> Show Error/Debug Log after the red error signs appeared and post the output you find there, this will help identify what happened.

Also please tell us what exactly you did. Did you use scan or lookup?

In general having the files put into “unmatched files”, but at least added to the correct album, is not so bad. You can usually just drag the files to the album or to the inidivudal tracks to fix this. If your files really have not information at all it is somewhat to be expected that Picard has a hard time matching the tracks. Scan (aka AcoustId fingerprinting) can help here, but not always.


Thanks for your reply. The log say “E: 18:23:45 Traceback (most recent call last):
File “picard\util\thread.pyo”, line 46, in run
File “picard\formats\mp4.pyo”, line 113, in _load
File “mutagen_file.pyo”, line 38, in init
File “mutagen\mp4.pyo”, line 1029, in load
error: Not a MP4 file”

I have convert the files with fre:ac and convert from FLAC to AAC with file extension .mp4. I tried again with file extension .aac but Picard not copy any file to unmatched files.

Should I try another converter or what you suggest?


So the files you have are likely pure AAC files, and not MP4. You cannot simply change the file Extension to make them MP4, I think fre:ac should be able to create MP4 files.

See also https://tickets.musicbrainz.org/browse/PICARD-490 for more background.


Sorry for my bad English. I converted them FROM flac to AAC but Picard cannot recognize them in the unmatched files.


Yes, we get that. See what @outsidecontext wrote:


@Freso Why do we want him to change the format, will that help with his problem of the files not matching?


The problem seems to be that @dator400 has files that are not AAC files in a MP4 container (such as e.g. iTunes store uses) but “pure” AAC files (which should have the file extension .aac). Those files have only a very basic header, and Picard can not tag them. The ticket above requests this, which other software does using either ID3 or Ape tags. Player support for tags varies here, too.

The best option right now is to put the AAC files into a MP4 container, which will allow full and standardized tagging. From what I can see free:ac should be able to create MP4 with AAC, also (AAC is the default lossy codec for MP4).

See also https://en.wikipedia.org/wiki/Advanced_Audio_Coding#Container_formats for a description of possible containers for AAC and more technical details.


Great, thanks for the detailed info!!

Edit: A bummer that you can’t just use FLAC though @dator400, too big or not compatible with your music player?


I convert TO .m4a format and now can I see all information in at least VLC. I have no car rental until December but I assume it work now. Thanks!