With VPN on, no access to website and Permission denied error

I am trying to set up MusicBrainz Picard with a new computer but will only connect with the website when the VPN is off. I have an older computer that works just fine with a VPN on, so why doesn’t it work on the new one.

Here are the differences:

Older laptop:
using wifi
can ping and view musicbrainz.org, everything works in both the program and browser

New desktop:
using ethernet, allowing program through Windows Defender Firewall,
cannot open musicbrainz.org in Firefox or Edge when VPN is on
“Firefox can’t establish a connection to the server at musicbrainz.org
a general failure when I ping musicbrainz.org

Here are the similarities:
using same home network, same VPN, newest version of Picard (2.5.6), testing same music files, both Windows 10 Home version 20H2, using Firefox as default browser

The error I’m getting is Permission Denied (QT code 99, HTTP code 0):
E: 18:31:28,903 webservice_init_._handle_reply:457: Network request error for https://musicbrainz.org:443/ws/2/release/da3b2c44-55b2-4672-9a1b-0da8668b1c41?inc=release-groups+media+discids+recordings+artist-credits+artists+aliases+labels+isrcs+collections+artist-rels+release-rels+url-rels+recording-rels+work-rels: Permission denied (QT code 99, HTTP code 0)
E: 18:31:28,903 ui\item.error_append:96: <Album da3b2c44-55b2-4672-9a1b-0da8668b1c41 ‘’>: Permission denied

I’ve tried to add static routing via Command Prompt
route -p ADD MASK

Should I try without ethernet? Maybe try " Prefer IPv4 over IPv6 in prefix policies"

That’s clearly a general network error and not specific to Picard.

My first suspicion would be that the network you connect to uses a DNS server that does not resolve MusicBrainz.org. Setting a different DNS server might help here.

What exactly is the output of ping? What happens if you ping the IP, does that work?

What is the output of

tracert musicbrainz.org

Is this for the same VPN or a different one?

1 Like

The ping results are the same.

Pinging with 32 bytes of data:
General failure.
General failure.
General failure.
General failure.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

here is the tracert result:
>tracert musicbrainz.org

Tracing route to musicbrainz.org []
over a maximum of 30 hops:

1 General failure.

Trace complete.

About changing a DNS server, I’ve looked on my Xfinity Comcast router settings and can’t find an area to change any DNS settings. Maybe its a Comcast issue: https://support.opendns.com/hc/en-us/community/posts/220008307-Configuring-a-Comcast-Modem-Router
I don’t want to have to add another router for this issue.

I’m using IPVanish on both computers and same version, protocol (OpenVPM), and same server.

So DNS is working (it is successfully resolving the domain name to the IP), but the IP cannot be reached. Have you trouble accessing any other websites or only musicbrainz.org?

1 Like

Usually, I have an error with costco.com
Access Denied
You don’t have permission to access “http://www.costco.com/” on this server.
I usually have a VPN server in same country, but a different time zone.
Found out if I change to a server with the same time zone as me, costco works.

But still the same problem with musicbrainz.org

The problem with changing servers is that I have to verify accounts again like yahoo or amazon. So if I can keep the original server, I’d LIKE to.
I don’t know a huge amount about different VPN servers and which countries or zones are best/worst.
I guess if I want to visit costco, change to my time zone.
And if I want to do anything with musicbrainz, disable VPN.
I just thought someone might know a workaround/explaination because its possible with my older laptop.

Whose VPN are you using? I’ll connect to MusicBrainz from all kinds of random countries via VPN, so it is not MusicBrainz stopping you. MusicBrainz won’t care where you are coming from.

You may get a better answer on the forum of the VPN people.

WiFi vs Ethernet will not be the issue. Don’t start messing with IP v6 and stuff you don’t really understand. Also that static route is not going to help. It seems to me like your attempted “fixes” will more likely be the real issue here. Clear those fixes away and go back to a plain VPN and try again.