Weird text scaling issue

Finally a new setup and chance to tag all my great music files that have no tags. But, big problem on new computer:

All over MusicBrainz Picard (and one other software) I have text obviously misadjusted for the size of the box/column. So it’s not readable.

I have a 4K screen, could this have something to do with it ?

I’ve unsuccessfully tried adjusting various scaling settings in Windows 10. But that changes universal settings, the problem is only visible in a few programs. It looks like this and is recurring throughout the program so makes it unusable:

Thank you very much for any help.

1 Like

I’ve been seeing this, too. It’s not the scaling, if you look closely the font is still the same size. It’s just more than one line and Picard is showing halfway between lines. Very strange.

The text boxes on the Picard screen have WordWrap on and are Centre Justified (by height). So that is leaving to the odd text.

It is almost as if Picard should be resizing the rows by height to make these items visible… but isn’t doing that resize automagically.

@maria95 Can you make your Picard screen larger? I am guessing that you have larger font scaling on the screen due to its size. What happens if you try and make Picard bigger - maybe even full screen. Does the issue settle and go away then?

“It is almost as if Picard should be resizing the rows by height to make these items visible… but isn’t doing that resize automagically.”

I’m running Win 7 & 10 full screen. One has a 16" monitor & the other is 24". On occasion I get the “more than one line” in a single block on both. I’ll play around with this too and we’ll see if its a windows thing or Picard.

1 Like

Okay, on the bottom of my Picard screen, I can force the double line stuff by putting my cursor on the line that divides original value and new value and sliding it left or right. I pulled up BeeGees number ones first so I would have something in the boxes. Looks like Picard is trying to save space. :smirk:


@maria95. One thing that I noticed after reading through this thread is that your columns might be a bit tight and Picard is trying to squeeze them into a “defined” space. Try putting your cursor on one of the column dividers and slide it to the right or left to see what happens. I would think Picard should allocate more room “automagically” but it doesn’t. I don’t have a cure but others have much more edgeamakation than I do. Stay tuned!:grinning:


Nice research there @Llama_lover I used to write software myself. So it looks like the rows are set to a fixed height but with word wrap enabled. This is why you are seeing a slightly odd result.

In the next build either the word wrap should be turned off and go to moving the dividing line (tip - double click the line to push it to max width).

Or some rows need to be able to expand in height. But that does get very messy looking very quickly.

Personally I think it should be option one and make everything stay in neat same height rows, leaving the user to adjust the width.

The problem with testing is that all of us spend too much time on standard sized screens with standard sized albums. In future for any test I’ll be getting my Chumbawamba collection out and will test with this one :wink:

That should test out any max lengths pretty well. hehe…


I just don’t know where to start to fix this issue.

Have you tried resizing the boxes?

Move your cursor into the Column Headers. Now watch carefully as you get to the dividing line I have marked above. As you get here you should find the cursor changes. When that happens you can LEFT CLICK and grab that dividing line. That should let you drag the box wider.

If you are careful with your aim, you can also double click that dividing line and it should make the box “full width”.