Various Artist CD's

After scanning files from a cd of various artists, the results come from multiple albums.
When saving, it doesn’t number them in the correct order. Instead it numbers them by the numbers they were in each album they were found. So then you have 5 # 1’s, 6 # 2’s, etc.
Anyway around this?

1 Like

‘Scan’ ignores existing tags in your files and looks for the same audio ‘fingerprint’ in the database. This means it will split your files up, and find a lot of compilations etc.

If you already have your files in an album folder, with some tags, the first thing to try is:
Cluster > Lookup

By the way, you can see how the files will save when you look at the right hand panel (after clicking scan or lookup). Expand an album on the right, and you will see green squares next to tracks that one of your files is matched to. Try dragging and dropping that track onto a different track or album on the right, and see what happens. So, one of the solutions to your issue would also be to select all the files on the right and drop them onto the correct album.

Hope that helps! If you have any more questions just ask. Oh, and an obligatory reminder to always test or run Picard on a copy of your files. Saved changes cannot be undone :+1:


Also take a look at the settings in Options > Metadata > Preferred releases, you can lower the priority of compilations and raise the priority of albums and other release types you care about.

Also remember you can load any release from MusicBrainz into Picaed and tag your files against them. See Retrieving Album information — MusicBrainz Picard v2.7.3 documentation for some recommendations.