Upcoming Picard release needs testers and translators

Tags: #<Tag:0x00007f34241b51c0>


https://tickets.metabrainz.org/browse/PICARD-700 isn’t included in this release, nor is https://github.com/metabrainz/picard/pull/553. If a consensus is found on it, it may be in 1.4.1, but 1.4.0 is now frozen feature-wise.


oh right, sorry for some reason I thought I saw it listed but must have made a mistake.


The ticket had “fix 1.4” set, but wasn’t resolved/closed, so i guess this is why.


I hope this is the right place to post this. I am encountering some issues and I’d like to figure out why they happen until the stable version comes out. When using lookup/scan, I’m receiving errors very often (tested both 1.3.2 and 1.4 dev7). Trying to lookup/scan 10 releases and on average every 3rd release either doesn’t get identified or is displayed as “could not load album (MBID)” on the right pane. I suspect it might be related to my router, but because currently I don’t have access to it, I can’t try to see what happens when the router is disabled. Is there any other way to figure out if this is indeed an issue with my router? Looking at the log, there are network issues as well as some other issues, for example “UnicodeEncodeError” or if a track contains ’ character, Picard will use " character instead of the ’ character on the “Moving <File u” line (this might be intended, though). In this example case I dropped 10 releases into Picard, clustered them, selected them all and clicked on lookup. 1 release has been correctly named, 4 releases have been correctly identified but not correctly displayed (need right click + refresh) and 5 releases weren’t even matched properly. And sometimes some of the releases will be correctly displayed, but I can’t switch between different releases from the same release group so it seems like the releases are just not properly loaded (and also work after a refresh). Many thanks for helping me investigate this issue.

Here is how it looks like in Picard: http://i.imgur.com/z0DVSE7.png
Here is the complete log from this session: http://pastebin.com/GWdpXYLL


For what it’s worth, I tagged quite a lot of files yesterday and I had lots of releases that couldn’t be loaded either (not as much as one in three though). I hoped these issues would have been solved with the server move, but apparently not (I also started getting search errors on the website again). So it is more likely to be a server issue instead of a Picard one.




Tried again at 3 am in the morning and this time everything worked fine (20 releases). The “UnicodeEncodeError” is still present, but I guess it isn’t anything serious. I’ll try it again during the day and on wi-fi on monday to figure out if this is a server problem or a problem with my router.


UnicodeEncodeError should be fixed in last versions. It was happening when logging on windows console. The fix will be included in upcoming 1.4.


Glad to hear that. Btw. I haven’t experienced any network issues recently, so I guess the issue I had is now fixed.