Unable to Match Downloaded Songs

I recorded some songs from a music service (about 20 or so). They were recorded to WAV, then converted to AAC 320 VBR using Foobar. They sound perfect. Instead of manually entering information, I decided to run them through the latest Picard. I figured that these should be a breeze for Picard to recognize given the purity of the source. My settings for Threshhold were my usual 80, 80, 80 in Options.

Instead, while it recognized correctly 4 of them, the remainder came up with no matches. And these were not random album cuts, but songs that on their own had made the top 200 of the year on the radio, not even album versions, some pretty high.

As an experiment, I tried lowering the thresholds to about 40%, and Picard started matching, but to wrong songs.

Why wasn’t Picard matching?

Lookup uses the metadata of your file.

Scan uses the AcoustID service, which requires somebody else to have submitted their scans prior to you, as well as matching track length.

Given that you didn’t produce your file in a standard way, it’s likely that you didn’t fill in the necessary fields for Picard Lookup to do anything productive, and it’s possible that your audio file’s reported duration is too far off to match an existing AcoustID entry.


Thanks. Will force a Scan. I had thought Picard did an automatic SCAN since as soon as a folder is selected, the right column fills up with matches.

Nope. None of the songs that didn’t automatically match when the directory was loaded got matched when I forced a Scan.

“and it’s possible that your audio file’s reported duration is too far off to match an existing AcoustID entry.”

But wouldn’t converting to AAC with foobar not convert silence at the end if the recorded wav was too long?

Also, I just took at look at the Info Picard reports of one of the songs that did not get matched. It shows 48000 HZ. Shouldn’t it be 44000 Hz. The coding the foobar did is as follows:

qaac 2.71, CoreAudioToolbox, AAC-LC Encoder, TVBR q127, Quality 96


Followup: Nope, that didn’t go anywhere. I tried to Scan the original Wavs. Same lack of matching.