Unable to link a MusicBrainz hosted discussion

Tags: #<Tag:0x00007f050996f0b8>


Continuing the discussion from When to use Aliases for artist name:

I have not yet seen any problem linking anything.
What kind of discussion did you want to link?
Old forum topic? Edit notes?

MusicBrainz Solr Search Server Completion and Results Optimization

I’m not sure, ther was 3 types of links in OP:
Edit notes,
Forum thread (new forum)

I prefered to edit them out and make the OP consistent without them so to save time i didn’t try removing them one by one…


it’s got to be the documentation… my posts in another thread linking to it got flaged as spam…


More precisely this post (and another one in that thread) Legal Name instead of Artist Name appearing in google search results

linking to https://musicbrainz.org/doc/Style/Artist#Performance_names_and_legal_names

I get the feeling, that since i tried to link to it again, the system thought i’m abusing it…

EDIT: now i earned a “first link” badge :confused:


That’s pretty strange, I had seen your posts with the links in this thread just fine for a while.

@Freso: Is there some auto-flagging for external links? If so, can we tweak it? Or was this some misuse of the flag feature?


Yes, @Freso should definitely add some domains to white_listed_spam_host_domains (ideally all the *Brainz domains including subdomains, though I’m not sure if it accepts something like *.metabrainz.org).

On a related note, if you are stopped by anti-spam measures, it’s not a good idea to try it again and again and to write further off-topic remarks … that is exactly what spammers would do and causes even more anti-spam measures to kick in. Wel’ll look into it, yes, but it may take a while until someone notices that dozens of flags have appeared in the moderator inbox.

I think I unhid the hidden posts, deleted the off-topic noise and cleared the flags for now. When *Brainz will be whitelisted, this shouldn’t happen again.


Congratulations to @basspistol for being the first to trigger Discourse’s automated spam flagging! :wink:

I have added musicbrainz.org and metabrainz.org to the white_listed_spam_host_domains setting, so linking to these should no longer cause any spam detection algorithms to trigger. I’ll add the rest of our domains later.

(Edit: The rest of our domains should have been added now too, btw.)


haha :slight_smile: glad my stubbornness was of any help :slight_smile:


I just now got „New users can include only 2 links“ or something to that effect in my first post. It included two links to https://musicbrainz.org and one to https://wiki.musicbrainz.org
After editing out one link, Discourse still popped up the same warning (one of us has problems counting). De-linking another URL finally worked.

(Let’s see if this post goes through.)




Huh. musicbrainz.org links should not count against that.

Edit: Added github.com to that list as well. Try again?


Does it go by hostname? I.e. are we sure http_s_ (which I used) is included?

This problem is a bit hard to reproduce for us, because one will lose the „new user“ status after a short while… I think someone with admin privileges, who can batch create a lot of users (or put the same user back to „new“ a couple of times) is needed for serious testing.


It’s supposed to cover everything on that domain: