Unable to add files with right quotes in the filename

Tags: #<Tag:0x00007f0509286148>


For example, “01 - He Ain´t Got Rhythm.flac” - the file browser interface displays it as “01 - He Aint Got Rhythm.flac”, and trying to add it results in an error. This is in 1.2 on Ubuntu.

Is there any kind of option that could get around this problem?



(Note that ´ isn’t a right quote or apostrophe – that would be ; instead, it’s a grave accent.)


This looks like a bug. It does work like it should on Windows 7. Can you check if there are other special characters that give the same problem?


Definitely sounds like a bug, and since it is already shown wrong in the file browser this is probably a bug with Qt. What filesystem is this?


This Picard version is also pretty old, maybe update to the latest version. What version of Ubuntu is this?


It’s Ubuntu 14.04.5. Yeah, I thought it might be Qt or whatever else it’s using to browse files. I tried to do a drag & drop as an alternative but that didn’t work (it wasn’t the native Ubuntu file manager, I think). It’s an ext4 filesystem.

It’s a shared system so I can’t directly upgrade things but I’ll ask them about moving to a more recent Picard. I tried allowing multiple directories to see if that gave me a different file browser but no. I was wondering if there were any other configuration options, or any other ways to add files for processing.


  1. Picard 1.2 is quite old, we are about to release 1.4 and you should be able to install 1.3.2 on Ubuntu 14.04 from https://launchpad.net/~musicbrainz-developers/+archive/ubuntu/stable
  2. which error do you get ?
  3. did you try from command line ? picard -d yourfile and post the debug log (remove passwords eventually, 1.2 may show them… fixed in later versions)


passing on the resolution from the machine admin:

"It took me a while to figure it all out, but I found the issue in the end. To safe you my whole journey the bottom-line is the following: Picard, even the latest version, has a config file that tells it how to start it from within VNC, and it does not specify which encoding type to use. It defaults not to the server encoding, which is the proper UTF-8 encoding standard, but some random one.

“I made the changes to the Picard config to start in UTF-8 and it works now.”