Tagging Scripts Not Running

picard
taggerscript
Tags: #<Tag:0x00007f646a0a4e18> #<Tag:0x00007f646a0a4cd8>

#1

I’m not sure what I am doing wrong but even the examples provided in the documentation don’t run. The Debug Log shows nothing about scripting only that it is updating the file. I’ve used Picard on another computer and the same scripts ran fine. Are there any requirements or known issues?


#2

A bit more information please. What version of Picard? What platform / operating system? Is it not tagging the files or not renaming them (or both)? Have you checked the obvious settings under options (e.g.: “Rename Files”, “Save Tags”, etc.)? Is it a naming script or another script that isn’t working?


#3

I’ve tried versions 1.3.X to 1.4.2 on Windows 10 64-bit. It is tagging the files correctly but not applying the tagging scripts. For example, I want to remove the month and day from the date by using $if(%date%,($left(%date%,4))). It does not apply and saves the date in the original format even though I have scripting enabled.


#4

It sounds like you might not be using $set(…) to set the value of the date variable. Can you post the script? I was also going to suggest that some variables might need to be changed using a plugin, but that probably doesn’t apply in this case if this script has worked for you before.


#5

I uninstalled my Python installation and it started working. I’m not 100% sure if that’s what did it though.


#6

Beats me. The main thing is that you got it working.