Tagging/renaming files

filenaming
taggerscript
Tags: #<Tag:0x00007fe3d39ea458> #<Tag:0x00007fe3d39ea2a0>

#1

I’ve had this problem before, on a different computer, but the solution I used before is no longer viable on my new computer, apparently.

  1. My tags show up properly in Japanese, but when renaming the files, all the foreign characters are replaced with underscores ____. I have played with just about every tagger option I have, but none of these seem to work for Windows 10 filenames

  2. I want it to rename the files so I have - , but
    $if2(%albumartist%,%artist%)/$if($ne(%albumartist%,),%album%/)$if($ne(%albumartist%,) ,)$if(%_multiartist%,%artist% - ,)%title%
    just yields the track name, despite the example showing it should include the name.

So, to summarize, I should be getting
Sakanaction - 新宝島.m4a
But instead I’m getting
___.m4a

Any advice on fixing these issues would be appreciated…

–EDIT–
Quick update the former issue is resolved but now I’m still having the latter issue with renaming.
I should be getting
Sakanaction - 新宝島.m4a
But instead I’m getting
新宝島.m4a


#2

Your rename script
"$if2(%albumartist%,%artist%)/$if($ne(%albumartist%,),%album%/)$if($ne(%albumartist%,) ,)$if(%_multiartist%,%artist% - ,)%title%"

will only display the artist if the release contains multiple artists. (the $if(%_multiartist%,%artist% - ,) part)
Try removing the references to that like:

$if2(%albumartist%,%artist%)/$if($ne(%albumartist%,),%album%/)$if($ne(%albumartist%,) ,) %artist% - %title%


#3

Thank you much for the info. Fixed my issue right up.


#4

It would not be for myself but, for this forum’s usefulness, could you tell how you did solve your « all non ASCII characters are being replaced with _ » problem? :cat2:


#5

Current settings are
Tags

  • Write tags to files checked
  • ID3v2 version 2.3
  • UTF-16
  • Everything else is unchecked

File Naming

  • “Rename files when saving” checked
  • Everything else is unchecked, except for 'Delete Empty Directories and Windows compatibility, which don’t give me any option to change them