Tag Data Not Saved to Files

Hello Everyone,

I’m using to Picard 2.2 64-bit to tag .wav files, but I’ve been running into issues.

After I cluster and then scan the files, the tracks show up in the right window with green check marks even though I haven’t clicked the save button.

Also, the tags arent actually being saved to the files themselves. The files that are check marked don’t show any metadata in the bottom window of Picard, or when I right click the files in windows file explorer and go to properties.

Here is a screen capture walkthrough: Walkthough Gif

Here is the error log: Error Log

Here is my Options > Tags Page

Here also is my system information:

I was able to avoid the automatic check marks on scanned track with Picard 2.1.3 64-bit, but the metadata is still not being saved to the files with that version either.

Troubleshooting steps I’ve tried:

  1. Checked to see if files were “read-only”
    The files are not in read only mode
  2. Ran the program with admin privileges
    Same issues occur

Any suggestions for further troubleshooting?

All the best,


Picard does not currently support saving tags to WAV files, see the FAQs. The general recommendation is to convert the WAV files into a lossless format like e.g. FLAC.

That Picard 2.1.3 does not show the checkmarks is basically a bug which was fixed in 2.2 (Picard was showing all tags even though they cannot be saved).

Tagging WAV files with ID3 tags might come in one of the next releases, see


Got it, thanks for the quick response!

I think I just saw the WAVE file on the comparable list, and didn’t see the footnote.

Thanks again for your help.